Import data in excel that run in office 365

Hi I ve a problem with the data produced during image analysis. When I trying to load that one in Excel the data appear in a single column. Many thanks in advance for all suggestions.
Regards

Maybe you need to specify what is the field separator when opening those files. XLS files are not really Excel files. You can open them with any text editor.

Hi Gabriel, pls find the file attached such as example. The file not permit to open as text and so I don’t have the possibility to use te text import option. Regards

This is not an image-related question so not sure if it belongs to this forum. Anyway, since I am here:

This is a CSV file (i.e. Comma/Character-Separated Values file. To import into Excel, use the text import wizard under the Data tab > From Text/CSV

Hi,
I know the procedure but the problem is that the file is opening in automatically in Excel and not permit to me to open it as txt or csv file. The result is the file attached shown above.
Regard

Two other suggestions:

  1. Rename it to CSV then it will probably ask what are the field delimeters.
  2. Use something else. Libreoffice Calc works fine and it is free.
1 Like

Hi,
On the “Data” tab, there’s a “Text to Column” button that should do what you want.

Hello marco,
Just save your data as a TEXT IMAGE in ImageJ, then Excell will open it as intended.
Bob

No, you cannot save a Results Table as “Text image”. That option is to save images as txt files.

dear all,
many thanks for your suggestion but it isn’t possible to rename the file (as Gabriel wrote above). I can try to download the Libreoffice. Anyway I’ve attached the file if someone would to test and post here the solution I’ll be gratefull. Regard and Best Wishes.
Results box 11.csv (68.3 KB)

I doubt very much that you could not rename a file…
There is even an IJ macro function to do that:
File.rename(path1, path2) - Renames, or moves, a file or directory. Returns “1” (true) if successful.

Did you try the “Text to Columns” option in Excel I posted above?

There is also an I/O Option to select the “file extension of tables”. Set it to “.csv

Hi @macro, try Beth’s solution, also on this YouTube video as we are in YouTube times… https://www.youtube.com/watch?v=Z8hH-PSRDOw

Hi I ll try, the last one proposed seems ok for me. I ll send u the feedback. Many Thanks all of u and Best Wishes.