Images not appearing in test mode?

Hi,
I am trying to 3d segment cells in monolayer. I have 3 florescent probes (DNA, Actin, and Protien of interest). I am using a Z stack. I have been following the tutorial that is available at https://github.com/CellProfiler/tutorials/tree/master/3d_monolayer
however when ever I try to test any image processing I only get the x portion of the image no Y it all seems stacked on top of itself. image
https://drive.google.com/file/d/1lrGlCVxDDMtjNZdJSjh5z_-XIW1JR1cl/view?usp=sharing
Thanks
Saranne https://drive.google.com/file/d/1lrGlCVxDDMtjNZdJSjh5z_-XIW1JR1cl/view?usp=sharing

Hi @saranne1983,

It looks like the image you’re trying to use contains a z-stack in multiple fluorescence channels, which effectively makes this a 4D image which the 3D modules can’t interpret. You’ll need to export or split each channel into individual z-stacks before trying to load it into CellProfiler.

Hope that helps

Dstirling,
Ok so I have made tiff’s of all the individual z stack images in each channel and tried downloading just one channel but cannot get the system to recognize the z series. I guess I am struggling with entering the following input
^(?P.*)_xy(?P[0-9])_ch(?P[0-9])
My file name T260xpiezo1x_008Z01C1.tif Where Z goes to 11 and C1 stays the same since I am only loading one channel.
Do I need rename all my files to Z–>xy ? or can I do something similar to what is below?

^T260xpiezo1x_008(?P.*)_Z(?P[0-9]{2})_C(?P[0-9])

Hi @saranne1983,

Would you be able to upload one of the new files so I can take a look?

@saranne1983,

The expression for your file name (T260xpiezo1x_008Z01C1.tif)
^(?P.*)Z(?P[0-9]{2})C(?P[0-9]).tif
Still you could share the file.

Regards,
Lakshmi
Fujifilm Wako Automation (Consultant)
www.wakoautomation.com
For CellProfiler training or optimised pipeline write to,
lakshmi.balasubramanian.contractor@fujifilm.com

Read more on our site.
Yokogawa CV8000 - The Ultimate in Confocal HCS
https://www.wakoautomation.com/products/yokogawa-high-content-imaging

Join us at, https://www.slas2020.org

Thanks I tried the labeling that you advised with no success.
https://drive.google.com/drive/folders/1MfYqebxmPq0gpFlMAWww1l-LIZgD-upH?usp=sharing

Here is a link to the tiffs so you can try it out. I am still getting a metadata orange x when I tried what was suggested and no changes in the series and frame data columns…

Thanks for the continued help,

Saranne

Hi Saranne,

That format is also not right; for 3D, you need one stack per channel, so if you had 3 colors and 11 z planes, you need 3 image files, each with 11 slices. Hope that helps!