Imagej2-plugin-tutorial: not showing up in the menus

Probably my question is rather basic, but I am having trouble with getting my new menus show up in the imagej2 toolbar. What I did is I cloned the tutorials repository and focused on the “swing-example” project. I changed the file names and “menuPath” tag’s value, and there were probably some inconsequential changes in the POM.
But when I run it, the menu item names I have created do not show up in the ImageJ2’s toolbar. From my understanding, all I have to do is to add the menu path in the annotation to the class.

Selection_140Selection_139

I have attached what I did, still no entry “XYZ” in the menu. What is wrong? I was just cloning the tutorials from https://github.com/imagej/tutorials/tree/master/maven-projects/, specifically, the swing-simple project. And modifying it.

I don’t see a swing-simple project in https://github.com/imagej/tutorials/tree/master/maven-projects/.

Can you please be a bit more concise in describing what you tried? I’m certain this would facilitate helping you.
Also: how are you running your project? Which IDE (e.g. Eclipse, IntelliJ?) are you using?

Thank you, Jan! https://github.com/imagej/tutorials/tree/master/maven-projects/swing-example
This is the swing-example I was talking about. Right now I have switched to modifying the “create-a-new-op” example from the same place, and now with much greater success. Reading twice the tutorials on ImageJ plugin development helped, too. Now at least my plugin gets picked up by runtime and appears on the toolbar.

Regarding this problem, I used two IDEs – first IntellijIdea 18.3, then had to download NetBeans and try it there. In both places I end up with “swing-example” being “unrannable”, whatever that means and however that sounds :slight_smile: – but you know when you see it. So, when I clone the imagej-tutorials master branch to my IDE, all the projects show as “runnable”, except two, as described in the other thread I’ve created: ImageJ2 Plugin Tutorials

I have to make an edit to my previous post: Now that I have opened it, swing-example is showing up again as runnable, had to follow IDE’s (Intellij) prompt to add some library related to imagej to classpath… Mystery.