ImageJ Spectroscopy Plugin not working

Hi there,

Im trying to use ImageJ to identify the wavelengths of certain colours in the light spectrum. I downloaded the spectroscopy plugin (http://www.astro.physik.uni-goettingen.de/~hessman/ImageJ/Spectroscopy/). and followed the exact procedure as listed on the website. Even then, under the spectroscopy plugin, Calibrate spectrum would not work and as a result it would plot a wrong graph. Funny thing is, the software with the plugin worked perfectly on a Mac OS device but not on a windows device. I was wondering if you can help me out with this issue. Thanks

Hi @Shevin_Lowe,

Would you mind showing us what you mean by wring graph? Furthermore, can you share an example image and detailed procedure which works on Mac but not on Windows? We could then better guess what might go wrong :wink:

Cheers,
Robert

1 Like

In additon to the reponse of @haesleinhuepf It would help if you start to compare the image pixel statistics on both OS after import to see if the plugin is responsible for the wrong calculation.

1 Like

Hi there,
The detailed procedure for acquiring the graph:

image

The Windows spectroscopy graph:

The Mac OS graph:

Mac OS spectroscopy graph

This time I was lucky just to get a graph close to the one I acquired from a Mac. Usually, the Windows graph does not even display 3 peaks.

Thanks for your help,
Shevin

Hi there,
I did not notice a difference in the image pixel stats. Usually, when I tell the program to plot the graph in Windows, it does not even look close to the graph produced by the Mac.

Thanks for your help,
Shevin