ImageJ&Fiji unable to read Geotiff file format

Hi,

I need help to read my geotiff (.tif) file format. I have tried many options, using Bio-Formats plugin, using Image IO plugin and even using LOCI plugin all are not working. The image is grayscale image, but at Fiji/ImageJ it only displayed as blank black and blank white.

can anyone advice? i attached a sample of 2 images from many images that can’t be load into imageJ

It seems you submitted your post before the images finished uploading. Can you please edit your post and try again?

hi @imagejan can u please provide your email address as i tried to upload the image here but the status keep showing uploading without any progress…thanks

Please note that GeoTIFF can come in different special varieties and ImageJ is not a GIS. For some varieties
ImageJ might fail to open them.

However the Gdal library/software can open and convert most of them, see:

http://www.gdal.org/frmt_gtiff.html

http://www.gdal.org/

You can convert your image with gdal and then import the image in ImageJ. Most OpenSource GIS softwares using GDAL for reading and writing GIS formats.

GDAL can be used from the command line or using a GUI software.

Here is a nice link how to use it via command line (and more):

By the way, as you are familiar with R the library rgdal is a wrapper for the GDAL library which can be used to open georeferenced images with R.

I’ve written a simple BeanShell script in Bio7 which uses rdal to open GIS images. It also transfers the images to the ImageJ view, see here for example:

With the first action you should at least get some information about yout file format.

I’ve tried using GDAL to export the format from gtiff to tiff. If possible i need to keep the file format in tiff as other format tend to compress. Even conversion from gdal to tiff unable to read the image in imageJ. I need to used the morphological segmentation function that’s why i need to work on so that the image can be open in imageJ. Can someone please check my raster format and tell me what’s wrong and why the image can’t be open properly with imageJ and advise how to solve it? i can’t upload the image here as it is not successful even with so many try

This seems to be a *tif file created with the Lidar LASTools.

It contains a worldfile (*.tfw), see:

and an image pyramid (*.ovr)

see:

http://gis.stackexchange.com/questions/127816/how-to-open-ovr-files-in-arcgis))

and a kind of axiliary xml file.

Try to extract the Band 1 data (which I see in your screenshot) with gdal_translate:

The R ‘gdalUtils’ package also includes ‘gdal_translate’. The documentation has some nice examples:

https://cran.r-project.org/web/packages/gdalUtils/index.html

If that doesn’t help please post an example image.

yes…the worldfile carries the projection information.
I just tried to extract the band 1 data with gdal_translate…the results still the same even tried to build up the tiled similar as function in gdalUtils package…See image below, the left one is what displayed in imageJ/bio7, the right one is what the image is supposed to display

I’m sorry, can i have your email address as i can’t upload my tiff image over here

According to your image I think it is just the display range which leads to this result.

If you move you mouse over the white area which data is displayed?

You can change the display range here:

http://imagejdocu.tudor.lu/doku.php?id=gui:image:adjust

In the set min max value you can adjust you display range which might be the cause of the black and white display when the data range for the display can only be displayed as white because the values are much smaller or much higher.

A nice tutorial can be found here with similar results (go to section “32-bt greyscale” and open the solutions for the exercise - here they use the histogram to get and set the data display range):

yes…you are right…i just need to adjust the min and max value and brightness to make it works…i just wasted my precious 2 days just on files conversion

Your image example made the difference. Sometimes this is a simple truth.