ImageJ 3DViewer error

Hi All, @ctrueden @frauzufall @haesleinhuepf

I am getting below error when trying to start the 3D Viewer in ImageJ.

(Fiji Is Just) ImageJ 2.0.0-rc-71/1.52p; Java 1.8.0_202 [64-bit]; Mac OS X 10.14.6; 134MB of 7856MB (1%)
 
java.lang.NoClassDefFoundError: Could not initialize class ij3d.Image3DUniverse
	at ij3d.ImageJ3DViewer.run(ImageJ3DViewer.java:60)
	at ij3d.ImageJ_3D_Viewer.run(ImageJ_3D_Viewer.java:37)
	at ij.IJ.runUserPlugIn(IJ.java:230)
	at ij.IJ.runPlugIn(IJ.java:193)
	at ij.Executer.runCommand(Executer.java:137)
	at ij.Executer.run(Executer.java:66)
	at java.lang.Thread.run(Thread.java:748)

Caused by: java.lang.ClassNotFoundException: com.jogamp.opengl.GLException
	at java.net.URLClassLoader.findClass(URLClassLoader.java:382)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:349)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 20 more

Any ideas?
Thanks a lot!
Tischi

1 Like

Hi @Christian_Tischer,

I suspect your Fiji has an update site activated which removed a jogl…jar… Could you please check that the selected files exist in your Fiji installation?

Alternatively: Could you please try with a freshly downloaded Fiji?

Thanks!

Cheers,
Robert

2 Likes

In my case it looks like this:

tischer@Christians-MacBook-Pro pom-embl-cba (master) $ ls /Applications/Fiji.app/jars/jogl*
-rw-r--r--  1 tischer  staff   433K Jun  7  2018 /Applications/Fiji.app/jars/jogl-all-2.3.2-natives-macosx-universal.jar
-rwxr-xr-x@ 1 tischer  staff   345B Oct 28 20:44 /Applications/Fiji.app/jars/jogl-all-main-2.3.2.jar*

I guess either it has something to do with me having a Mac or my update site EMBL-CBA is screwing something up…

Interesting: I was just running the updater again…

…and in fact it spotted this:

And now it works :slight_smile:

Just for future reference: as of this writing, update sites cannot uninstall JARs from upstream update sites—they are purely additive. (What you could do is ship a dummy/empty JAR overriding a library you want to disable.)

Glad to hear! :smile:

2 Likes