Image Drag and Drop Blocked in Win7

cellprofiler

#1

CP Team: Using CP version 2.1.1 with Win7 and Win8.1. I have observed that the drag/drop image file list/file folder function does not work reliably in Win7, but seems to work without any difficulty in Win8.1. In Win7 I can load selected files through the “Load Images” tab but drag and drop does not work most of the time. I observe a symbol where the cursor would be, suggesting drag and drop is not allowed (circle with a strikethrough) when attempting it on Win7. However I have seen it work about 2 times when first opening CP, but this goes away when I close and reopen. I do not understand this, do you have any information that might help get at the cause of this. It is troublesome working with large image collections not to be able to drag the whole folder into the images box. Thanks, Paul


#2

Hi,
Not sure, but possibly an issue with your Java installation on the Win7 computer? I made a short screencast on Win7 here which shows how it should look (though I suspect that you already know this via Win8):
screencast-o-matic.com/watch/c2XYoceqqH
Note:
(1) that it also shows the circle with the slash through it when hovering over GUI elements that you cannot drop into, but it should change to an arrow when you are over the Image Filelist window.
(2) I show at the end of the screencast that you can right-click in the Filelist window of Images and “Browse for Images”, which could be a workaround if we can’t figure it out otherwise.

So my only hunch right now is to check to see if your Java is updated on your Win7 computer, as nobody else has reported this to my knowledge.

Thanks,
David


#3

I get the drag and drop problem on different machines running Win7 and Java JDK and jre, path set. No solution yet and the workaround is not optimal since only a limited number of selected images are loaded in one go (loading in thousands of images takes several separate browse tries)


#4

Solved for me:
This was an issue with conflicting Windows privilege levels and I had accidentally enabled Run as administrator, which prevents the drag and drop feature in CP


#5

Thanks, solved here too.