Ilastik start up fails - because of halloween (really)

Hi everybody,

I am new here and new to ILASTIK. I ran into an issue starting up and any help is much appreciated. A week back I installed ILASTIK 1.3.2rc1 and everything went smoothly. I created an image segmentation project and managed to work on it over multiple days. Today I tried to start up ilastik again and it fails with with multiple errors (below I copied a few lines). I even installed an earlier stable version 1.3.0 resulting in the same problem. I am running it under windows 10.
Thank you and warm greetings,

Starting ilastik from “C:\Program Files\ilastik-1.3.2rc1”.
ERROR 2018-10-30 19:33:59,283 excepthooks 12928 1520 Unhandled exception in thread: ‘MainThread’
ERROR 2018-10-30 19:33:59,283 excepthooks 12928 1520 Traceback (most recent call last):
File “C:\Program Files\ilastik-1.3.2rc1\ilastik-meta\ilastik\ilastik\shell\gui\”, line 90, in launchShell
shell = IlastikShell(None, workflow_cmdline_args)
File “C:\Program Files\ilastik-1.3.2rc1\ilastik-meta\ilastik\ilastik\shell\gui\”, line 346, in init
File “C:\Program Files\ilastik-1.3.2rc1\ilastik-meta\ilastik\ilastik\shell\gui\”, line 602, in _loaduifile
File “C:\Program Files\ilastik-1.3.2rc1\ilastik-meta\ilastik\ilastik\shell\gui\”, line 585, in _replaceLogo
z.extract(filename, localDir)
File “C:\Program Files\ilastik-1.3.2rc1\lib\”, line 1484, in extract
return self._extract_member(member, path, pwd)
File “C:\Program Files\ilastik-1.3.2rc1\lib\”, line 1555, in _extract_member
open(targetpath, “wb”) as target:
PermissionError: [Errno 13] Permission denied: ‘C:\Program Files\ilastik-1.3.2rc1\ilastik-meta\ilastik\ilastik\shell\gui\ilastik-halloween.png’

Ahoy, i just found a workaround. Since Ilastik is apparently not getting the permission to open the Halloween related GUI files, moving to the future (adjusting system time) to the 2nd of November solves the issue.
Damn i wish i would have tried this earlier.
Next year I would rather have the treat instead.
Tim (Anna’s partner)

1 Like

Thank you very much for letting us know… I made sure that it works, yesterday, but I have to admit, only on linux. Will investigate the windows issue…

Hey there, so we made a new release that fixes it, you can grab it here:

please let us know if you encounter any problems with it

1 Like

Hi Dominik,
thanks for the fix. Works perfectly, now I can enjoy the Halloween vibe too :slight_smile: