Ilastik Input Data channel selection dropdown for each antibody is missing

cellprofiler
ilastik

#1

Hi so I am using Ilastik, and have input the pre-processed (smoothed, resized, cropped) TIFF images that were pre-processed using CellProfiler.

When I input the TIFFs into the Ilastik ‘Input Data’ box the channels for each of my antibodies is missing.

Please note that yes, I did include correctly the panel.csv listing each antibody, with column names “Metal tags”, “group id”, and “ilastik”, as the experimental design.

How do I have the channel selection in Ilastik?
Should I be inputting HDF5s of my images instead of TIFFs?

Thank you very much.
versions:
Cell Profiler version 2.2.0
Illastik 1.2.2


#2

Hi there,

I’m not sure I fully understand how you put the images into ilastik, but it sounds like you need to stack them by channel. Not sure we had this option back in 1.2.2, but we do now. Does it only load the first channel when you are trying to process it? Are the axes interpreted correctly (double click on the dataset to see/edit the properties)?


#3

Hello. first thank you very much for your reply.

let me clarify how the tiffs are input into ilastik.
we are using the IMCSegmentationPipeline from the BodenmillerGroup. We are using the imctools to convert the IMC text images.
however we realized that the cellProfiler IMCtools pipeline is missing the saveIlastik module. so this issue maybe related to the missing imctools module required to correctly save the ilastik files.

I am working on this. updates soon.