Ilastik image limit?

Hi @ilastik_team,

I’m facing an issue with loading/conversion of my data.

I have some (2612) individual tif slices from EM, total dataset is around 60Go, so I would like to convert it to h5 so please ilastik :smiley:

Loading the dataset result in a black image :

BUT if I use a subset of the dataset (11 slices) it works well …

Data Range, Normalize and Display Mode are the same…

BTW, I also tried to convert the image to h5 anyway and re-open it in ilastik, got the same black image.

Just to reassure you, the idea is not to do the training on this dataset.
Rather doing the training on some 3D-crops and apply it later on the large stack.

Any idea?

Thank you in advance for your help,

Cheers,

Romain

Hi @romainGuiet,

that is really odd. As a workaround you could try our Fiji import export plugin, to export the data once, just to confirm that it is an issue with the ilastik import. Just in order to be able to reproduce the problem a bit on our side, what format is your source data? (8bit tifs?)

Cheers
Dominik

Hi @k-dominik,

I did and it works!
I use fiji to convert and then open the file in ilastik, see below

Sidenote: it took 2h30 for 56Go, would you consider this ok ? or slow?

I just noticed that the shape descriptor is different.
Conversion with FIJI : tzyxc (1,2612,4602,4794,1)
Opening the tif list in ilastik : zyxc (2612,4602,4794,1)

Yes

Cheers,

Romain

Hi @romainGuiet,

great that it worked with the Fiji plugin.

So I heard from @wolny that this time is slow, but somewhat expected. The conversion is not super fast and could be optimized.

So now this thing ilastik has to be a bug…