Ilastik CPU RAM allocation

I find that when ilastik is not my active window, it runs slower (output files take longer to get exported, and I notice a drop in cpu usage too on my mac activity monitor, as you can see in the attached picture). Is there a way to keep ilastik running at full capacity even at background?

On a related note, is there a way to allocate more RAM/CPU to ilastik so that it runs faster?

image

Hello @ttan,

it seems windows assigns a higher priority to the process/window in focus. My colleagues @emilmelnikov and Fynn suggest to try raise the base priority of the ilastik process as described here: https://winaero.com/change-process-priority-windows-10/

Aye, seems like setting the priority to “Realtime” should be avoided, not to interfere with system processes.

For controlling ram/and cpu resources I’d suggest adding a config file as described in our docs

Cheers