Ilastik -- batch processing

Hi,
I am using Ilastik Multicut project to segment the 3d confocal images of the red blood cells based on their edges. when I try to create the probabilities in the pixel classification project I get this error:


and this is the list of selected features:

and if I tried the batch processing in the Multicut project (with one example to check if it works), even though the Multicut segmentation file is saved I get this error:

I am using version 1.3.3 on macOs Mojave.

Hi @Mehrnaz_b,

welcome to the forum!!

It looks like ilastik might not be recognizing your data as 3D data, but instead probably as 2D + time. So all the filters are then too big in 3D. Could you please add exactly which ilastik version you are using?

Thanks for your reply.

When I load a .tif file in the input data tab I should correct for the z instead of t. Then I exported .tif files with Fiji plugins as hdf5 then it is recognised as a z-stack. In the batch processing I am also selecting hdf5 files.
I am using Ilastik-1.3.3post3-OSX

Hi again,

The error with the pixel classification was gone with another set of data (don’t know why), but I am still getting the error for batch processing in the Multicut project. Any idea how can I solve it?
image
Thanks!

Hi @Mehrnaz_b,

is your data saved, despite this error?

Cheers

Dominik

No, just the segmentation file for the first input, the rest are not saved.

okay that sucks. We’ll look into it - in the meantime you could use the headless mode to process your data? Would be happy to help setting it up and get you going!

Thanks!
Got it working in the headless mode.

1 Like

good to hear that! thank you for letting us know @Mehrnaz_b. And don’t hesitate to make us aware of any other oddities/problems you find!