Ilastik batch error: list index out of range

ilastik

#1

Hi,
I am using ilastik 1.3 combined Pixel Classification and object classification workflow and am very happy with it, the results are really impressive!

Using this workflow, I try to process ~300 images using batch mode, but ilastik stopped after the first two with below error message:
ilastik-error3 1

Does anyone know a bit more detail on this error and how I can prevent it? Thanks for your help!

Edit: I have uploaded my ilastik *.ilp project file and two example images that reproduce the issue. The first image contains an abject and workswithout issue, the second image does NOT contain any objects and the above posted error is produced.

Edit: I tried the same with the latest version 1.3.2, but the error persist.

A few images at a time may be processed, but the error appears at one point. I see that it successfully exports an Object prediction image for each input image, but fails to export the feature table.
Hence my hunch is that for images that do not contain any Objects (a likely scenario in my case) the feature table expots fails because it is trying to retrieve values which do not exist.

Is there maybe a way to work around this issue? I did not find a way to exclude the feature table from being written, and there also some feature measurements that can not be de-selected.


#2

Hi @k-dominik,

Do you know if there’s a way to NOT export the CSV using Object Classification ? That would solve the issue ! :slight_smile:

Thanks !


#3

Hi @CellKai

first of all, thank you @lguerard for reminding me about this one.

About the issue, I think I fixed it. If you would be willing to reupload the project, I’ll happily confirm it :wink:

Fix will be in the next version (very, very soon)


#4

Hi @k-dominik,
thank you very much for the fix and new release, thats really awesome! I have not gotten to test it yet but I am sure its fine now! I did, however, re-upload the project to reproduce/test the error.
Thanks again for awesome ilastik!


#5

Hey @CellKai,

i checked out your project and did the batch export with the two images that were present in that folder. It worked :wink:
It was great to meet you at NEUBIAS.

Thank you for the support!

Cheers
Dominik


#6

yes indeed, same here! :slight_smile: