I can't see any single plugin under the plugin menu

Hi ImageJers,

Can someone please let me know how to use Plugins?
I do have all the sorts of .jar files in my plugins folder but could not find any of them in ImageJ. FYI I recently bought a Mac pro (MacOS Sierra), and am a kinda newbie of it. Would someone please let me know how to enable plugins?

Hi @trollingmundo

I’d recommend downloading the Fiji distribution of ImageJ (Fiji Is Just ImageJ). You can download it here.

Essentially, Fiji is a distribution of ImageJ that comes with a lot of plugins already installed, which facilitate scientific image analysis.

Hope this helps!

eta :slight_smile:

1 Like

MacOS 10.12 (Sierra) introduces a security feature called Path Randomization that can cause ImageJ to not work as expected. Path randomization is in effect if the “ImageJ home” path shown in the Image>Show Info window starts with “/private” and plugins are not installed in the Plugins menu. You can disable path randomization by moving ImageJ.app out of the ImageJ folder and then copying it back. If the ImageJ folder is in /Applications you will need to hold down the alt key while dragging ImageJ.app out of the ImageJ folder.


Hi Wayne,

Thank you for the input!

In fact, I was aware of Path Randomization after reading a documentation on the website. And I did move ImageJ.app out of the ImageJ folder to Desktop, and copied it back to the ImageJ folder before.

I’ve just double-checked the path in the Image>Show Info window, and interestingly, the “ImageJ home” path still starts with “/private”. So I just tried again moving ImageJ.app out of the ImageJ folder to desktop, and then copying it back to its original folder. Unfortunately, it still doesn’t work for me although I tried this numerous time.

I think, this might be unrelated to this issue but I cannot move files out of a folder in /Applications by holding down “alt” key, but “command” key worked for moving files, which is interesting to me as well…

Do you have any other suggestion to fix this issue?

Thank you!

Hi eta,

Thanks for your help in this.

I will try installing the Fiji. Hopefully, I can fix this issue without reinstallation, though. If this doesn’t go well, I think I should reinstall haha.

Thank you!
Trolling mundo

1 Like

Try moving the ImageJ folder to a location other than /Applications and then copying ImageJ.app out of the ImageJ folder and then back into the ImageJ folder.

1 Like

Hmm… that doesn’t work either. Ugh, this is so frustrating. It still shows /private/ in the path. I think I might need to try re-installing ImageJ.

Thank you anyway!

Oh Wow. I just deleted the ImageJ that I had installed, and installed Fiji a minute ago. It just simply works. I should’ve just done this earlier. LOL. Thank you very much eta.

Thank you very much Wayne too!

You guys are awesome. I really appreciate it.


1 Like