I cannot install ImageJ on Windows 10

Dear forum,

I can not install image J on my windows 10, I have tried all version of image j but always fail.

Any advice will be appreciated

Best regards


Hi @BrianW, welcome to the ImageJ forum!

To be able to help you with your problem we need more information. Can you please describe in more detail how the installations fails? Do you get specific errors? If possible attach screenshots.

Are you obtaining ImageJ from the Downloads page of the ImageJ wiki? It works on my Windows 10 system, as long as you place it somewhere you have write permission, such as C:\Users\<your username>\Fiji.app, and not in C:\Program Files.

If so, and it does not work, then as @gab1one said we will need more details of exactly how it fails. See Bug reporting best practices for guidance.

Thank you for your kind reply gab1one and ctueden,

I downloaded from Image j website

Download ImageJ 1.49 bundled with Java 1.6.0_24 (37MB), bundled with 32-bit Java 1.6.0_24 (44MB) or bundled with Java 1.8.0_60 (70MB).

every instalation it said I can not locate java

which file should I choose and how can I overcome the problem?



Please try the download of Fiji from http://imagej.net/Fiji/Downloads. If you continue to have problems, let us know.

I have also the same problem as Brian, I cannot install imagej with windows 10. I’ve downloaded the app from the link that you put here but in my case I have a message: "could not creat the java virtual machine. error: a fatal exception has occurred.

Can you help me?


Which download link did you use, specifically?

As of last night (see this post), the link I had put above ( http://imagej.net/Downloads ) is now dedicated to the “vanilla” ImageJ2 download, which comes without Java. The Fiji downloads are now listed separately at http://imagej.net/Fiji/Downloads (as well as http://fiji.sc/#download). I edited my post above to reflect this.

Unlike the vanilla ImageJ2 distribution, the Fiji downloads come bundled with Java 8, which might work better for you.

1 Like

Thank you for your quit answer and for your post of yesterday (sorry I did’nt read before wright this post), I’ve downloaded and its working perfectly! thanks!!!

1 Like

Hi, Can I revive this topic?
After reading through the above. Ive tried both the vanilla ImageJ2 and the most recent Fiji versions on Windows 10, (Microsoft Surface Pro). I cant get either to start up. For example, the error Im getting is

Could not switch to C:\Users\XYZ\Downloads\fiji-win64-20151222\Fiji.app

Is this a known issue (excuse my naivety if it is!)? Does anybody have any ideas?
Best, Adrian

Hi @awm27
your error “C:\Users\XYZ\Downloads\fiji-win64-20151222\Fiji.app” does not make any sense to me, but figuring that XYZ is not your real user name, the error shall be looking as “C:\Users\Your User Name\Downloads\fiji-win64-20151222\Fiji.app”, watch carefully that there are spaces in the name. Those spaces are LETHAL. Please copy your fiji to D:\Fiji.app, yes a different partition, or even to C:\Fiji.app, but in this case you shall set permissions to allow the scripts to modify it. Please let us know if you succeed.
Happy Fijing

Also, is there a specific reason you downloaded the Life-Line version from 2015, instead of the current release at the top of the downloads page?

I have not observed this problem with spaces in the user name. @awm27 What is your exact user name here? Is it really XYZ? Or something else? Do you have any non-ASCII characters in the name? Does it work as @BishopWolf suggests to move the folder somewhere else before running ImageJ-win64.exe?

If there is a bug here surrounding characters in path names, I’d like to at least document it on the ImageJ wiki at http://imagej.net/Windows#Troubleshooting.

tested! copy Fiji.app to D:\_My fijiñã@\Fiji.app and it opens fine, no problem at all. Moreover, copy to C:\_My fijiñã@\Fiji.app and it opens fine too. I even replicate his folder and it opens fine also, Windows 8.1 x64 here. Seems this old linux bug was not part of Fiji and since I always have my fiji in D:\Fiji.app I never worried about it.

So what remains is the imagejan question.

I am having a similar issue with installing Fiji Imagej. I started by trying to download the NIH website version on my microsoft surface book with windows 10, but when I would go to run the application, nothing would happen that I could see. Task manager would show that ImageJ was running but I had no way to find the toolbar. So I found this thread, uninstalled that and downloaded the fiji version that was recommended. I followed the suggestions on where to place the file. This time the Fiji logo at least appeared, but again, I cannot find the toolbar.

By “the NIH website version” do you mean ImageJ1, at https://imagej.nih.gov/ij/download.html ? That version of ImageJ is not Fiji. You can download Fiji from https://fiji.sc/#download

It is possible ImageJ is appearing off the screen. Did you have a second monitor plugged in, and then later unplugged it? You could try pressing Alt+space, M, enter, :arrow_left: and then move the mouse to bring the window back to your visible monitor. You could also try clearing the preferences by deleting the IJ_Prefs.txt file from the appropriate location (see the docs), which will force ImageJ to recompute the preferred location of its main window.

Finally, you could try launching ImageJ from the console and checking the output for any error messages:


A post was split to a new topic: Cannot launch Fiji on Windows 10

Dear Community “pals”.

I am new and I am having kind of similar errors, but slightly different. I am able to install Image J, or Fiji, updated both of them, etc. However I cannot open any image on the imageJ program as image tries to open but get frozen in the proccess at a 50-75%. I installed the programs in a (non-program files root) one or the other any time to test, always I installed them with administration permissions. I tried to mark in the Edit/Options/Input-Output area the option of Open/save, Proxy Settings (selected “or” and include the right proxy if I am at my institution) and select enough space in the Memmory-Thread capacity. I cannot continue…
The programs can update, the JAVA version is the right one, …
I have the latest version as today, the 64 bit one, and the JAVA 8 version as well. The version is the 1.52T and the JAVA one is
I would appreciate any hint? It is annoying to get trapped always in the image-openning proccess.
Thank you in advance

Anybody can hear me?
I am stucked in the images opening with either Fiji or image J version. I checked the console and it showed “Populating metadata”. The issue is that the program opens, I can select an image, I selected it to open and the program tried to open the image and dissaperad, although it is there.
How can I solve this problem?