Hyperstack Ordering

I’m trying to open a large image set where a user has generated simple timelapses. He visits three points/well of a 96 well plate and grabs a three channel (2424 x 2424 14 bit) image once an hour for 24 hours. The data is stored in a single 3 position .nd2 file for each well. When we open these images in Fiji, the Bioformats opener sees it as three separate files. However, the ordering is wrong. It treats the three XY locations as sequential time points. This also happens when I upload the images to OMERO, which splits the stacks in the same wrong way. I’ve tried going into the Bio-Formats Plugin Configuration and enabling “Use Nikon’s ND2 library instead of native ND2 support” and that has not improved things. I’ve also tried changing the Slice Label Pattern, but that hasn’t helped. I suppose I could open all three stacks, concatenate them and then split them using Image->Stacks->Tools->Make Substack three times over, but there has to be a better way. I remember that you could set the order of the Hyperstack from within the Bio-Formats opener, but this is now grayed out. Is there something that I need to do to re-enable this feature?

This might not be super helpful, but Zen for CZI files has a Split scenes (write files) option that can be used to split similar files per position (resulting in 3 files). Is there a similar option within Elements, which might make it more straightforward once you get to FIJI?

Hi. Could you upload one of the images to the OME’s QA site: https://www.openmicroscopy.org/qa2/qa/upload/
Or make it available in a public location?
Thanks!

I put a file up on the QA site. I had to crop it a bit. It is shorter than the orginal. I just deleted some frames, but the dimensionality has been maintained.

Thanks for uploading the sample files @UCSDNIC.

Just to confirm, with the latest Bio-Formats Im seeing 3 series, each with 3 channels and 18 timepoints. Is that the same as what you are seeing?

Its hard for me tell from viewing the file but is the issue your seeing is that the timepoints are actually alternating through the 3 positions?

So for example the planes would be as below:


BF                                  Expected
Series 1, Channel 1, Timepoint 1 -> Position 1, Channel 1, Timepoint 1 
Series 1, Channel 1, Timepoint 2 -> Position 2, Channel 1, Timepoint 1 
Series 1, Channel 1, Timepoint 3 -> Position 3, Channel 1, Timepoint 1 
Series 1, Channel 1, Timepoint 4 -> Position 1, Channel 1, Timepoint 2
Series 1, Channel 1, Timepoint 5 -> Position 2, Channel 1, Timepoint 2
Series 1, Channel 1, Timepoint 6 -> Position 3, Channel 1, Timepoint 2

Hi David,

This is correct. 3XY positions, 3Channels, 18 timepoints. I’m expecting what you have as BF, but I’m seeing what you have as Expected.

Thanks for confirming, unfortunately there is no easy way to swap these particular dimensions at present. We had received a similar report for this bug previously and I updated the existing GitHub Issue with the details from this thread.

We’ve now written a macro to deal with this. Going forward, we’re going to split the data by position.