Huygens professional doesn't give three channels on split

deconvolution
svi-huygens

#1

Hello all! I am using Huygens Professional for deconvolving images. These images contain three channels. However, huygens shows that the data has only one channel in the parameters window. But after deconvolution, when I save the images as tiff stacks, and convert them to hyperstack using FIJI, I get the three channels again. Reading through the manual, I found that once you click “Accept” after deconvolution, it goes to the next channel. But in my case I don’t get this option at all since again, the data is seen as single-channeled. Am I doing something wrong? This is the first time I am using this software.


#2

What format are your input files? Would you be able to share an example file?

You can also contact SVI Support directly, they’re usually very helpful.


#3

You could also invite SVI to post on this list. Commericial companies are welcome. It would be great to have them answer specific questions about Huygen’s, as well as contribute to the general discussions on deconvolution algorithms.


#4

@imagejan I am using Tiff files. I am trying to upload here, it says the file is corrupted :frowning: I can open it with FIJI though.
I uploaded to it here https://cloud.mpi-cbg.de/index.php/s/zQ306km4uIkoh6c.
Thank you!


#5

Hi gayaJ,

I just had a look at your tiff data, and it seems that your multi-channel hyperstack is read as one big z-stack (with 51 planes) in Huygens. You can very easily convert dimensions in the Huygens Software, but the methods vary slightly depending on which Huygens package you are using:

If you use Huygens Professional: select the image thumbnail and in the main menu go to ‘Tools’ -> ‘Convert’.
In the window that pops-up (see screenshot below), you can select the option ‘XY(ZCh) -> XYZCh’, and set the number of z-planes to 17 (since you mentioned there were 3 channels: 51/3 = 17). Click on ‘Run’ to convert the data dimensions.

convert-image-in-Huygens

If you use Huygens Essential: select the image thumbnail and in the menu go to ‘Tools’ -> ‘Convert’ -> ‘XYZ -> XYZCh’ This will not lead to a pop-up window like in Professional, but instead the convert tool is shown on the right-hand side of the main Huygens Essential Window. Click on ‘Run’ to convert the data dimensions.

This should convert your 51 z-stack image to a 3 channel image with 17 z-planes.

Note that since you work with bare TIFF there is no microscope meta-data included. For correct deconvolution and further processing, you will need to check & verify the microscope parameters by right-clicking on the image thumbnail -> ‘Microscopic Parameters’ where you can set the correct microscope parameters.
An example (for a different image) is shown below:

Note that the Huygens Software can also read many (raw) microscope vendor formats, including meta-data. We support for example: Leica LIF, Nikon ND2, Olympus OIF, VSI, OIR, Zeiss CZI, ZVI, LSM and many more. So if you also have your microscope data available in the raw vendor file format, then I would recommend to use those for an optimal image processing workflow.

To learn more about the many functionalities in the Huygens Software, I would also recommend to have a look at our extensive software manuals.
If you have further/other questions, then you may also contact us directly through our support page. If you don’t have an account to our website yet, then you can register for free.

Kind regards,

Remko Dijkstra
_Imaging Specialist _
Scientific Volume Imaging b.v.
Makers of the Huygens Software


#6

Hello Remko, thank you so much for the inputs. I tried it and now I get the three channels correctly. And you’re right about the meta-data, Ill have look if I can get the proper raw data/ meta data for these files. And thank you for the resources, I will surely go through them!
Have a good day!
Gayathri


#7

I just have one quick question on this again. I tried to do this conversion in batch but the option doesn’t show up in “tasks”. Do I have to do it for every image manually? Is there a way then to select the files in the main window for batch processing? When I do “select files” in batch processing it directly opens the data folder. I tried even to select files I want to process on the main window but the batch process option does not show the selected images. There seems to be not much about these small things in the manual too.
Thank you again,
Gayathri


#8

Dear Gayathri,

At this point it is not possible to use the batch processor for converting dimensions of images. The batch processor is primarily designed for batch deconvolution, and additionally it has the possibility to batch correct for Chromatic Aberration, batch-stabilize or you can use it as a batch file converter.
Are you using Huygens Essential or Professional? With Huygens Professional it is possible to also batch-convert dimensions of images via scripting (https://svi.nl/TclHuygens).
Could you perhaps send me an e-mail (remko@svi.nl) so that I can help you further with a possible batch-conversion script for your specific images and so that I can send you a temporary license for Huygens Professional (in case you work with Essential)?

Kind regards,

Remko