How to Windows Pileline in LINUX-filenames can have no space

Folks,

I am trying to test a headless CellProfiler2 that I have compiled for a LINUX cluster.

I want to test the command-line access to a pipeline.

I downloaded the ExampleVitra.zip file and ran it on a 64bit windows machine where it ran to completion.

When I attempted to run the program on the LINUX cluster, I get an error about write permissions.

The directory in question has “world” write permissions so I don’t think that’s the problem

The image filenames are something like “Col1 Something_Somethingelse.tif” Ie there is a space in the name.

The error says
"IOError: [Errno 13] Permission denied: ‘/home/hazards/CP2ILASTIK/ExampleVitraImages/Channel 1-01-A-01-00**_Outlined**.tiff’"

I changed the names of the tif files to remove the blank space in the name (eg “Col1_Something_Somethingelse.tif”) but I still get the same error.
Is there a way to change the cp file to make it LINUX-capable?

What happens if you run CP as sudo (if that’s possible)?
-Mark