How to prevent IdentifyPrimaryObject from dividing one cell into two

Hello,
I am new to this software and am trying to find a way to quantify biofilm cells. I have reached a problem at the identification stage where one cell becomes counted as two. Is there a setting that can be changed or addition to the pipeline made to prevent this? Thanks.

500um 29hr016.tif (9.3 MB)

Biofilm Quantification Project v2.cpproj (1.0 MB)

Hi @Pedersen5,

The settings for declumping are within the IdentifyPrimaryObjects module, to access them you’ll need to enable “Use advanced settings”.

There are a variety of options for this part of the process, but you may want to experiment with changing the size of the declumping smoothing filter to start with. It’s worth keeping in mind that such automated analysis will never be perfect, so you might expect the occasional cell which is split in two, or pair of cells which are joined together incorrectly. You might want to take a look at this blog post for further guidance on what to aim for.

Hope that helps!

2 Likes

Sounds good, I’ll look into those settings and the other post. Thank you for the help.

1 Like