How to force analyze particles to be limited to threshold where it does not?

Hi everyone!

I am trying to use “analyze particles” in Fiji for a binary stacked tiff file; however, the “analyze particle” considered including holes automatically although I unchecked “include holes” and checked “limited to the threshold”, see the image. Is there any idea why that happened?

Regards
Abdullah

I used “Watershed” for now, but I would like to know another solution.