How to change a project from the m2 version to the m3 version?

Dear community, maybe you can help me to convert a project that is in the version of QuPath 2.0 m2 to the m3 version.
Please consider that we have little knowledge in programming and technical programming language.
Thank you.
Best regards.
Carolina

Have you looked here? Pete wrote a script that seems to have worked for others.

2 Likes

Check the script, but my query is where I should paste it.
I tried downloading the script that is in a zip folder and run it as follows:

But it generates error

The screenshots make it look like you are running the script from 0.2.0m2. The instructions in the script should say to run it from the new project in m3.

1 Like

You don’t have a project open to import the project into. The instructions indicate you need to have a project, be in 0.2.0m3, and then run the script. You can read more about projects here. I figured if you had a project from 0.2.0m2 that you would be used to projects :slight_smile:

1 Like

The project if it is created as you can see in the first screenshots from m2. I had a confusion where to enter the script. But I understood that you enter from m3 having a previously opened project, but when trying to open the project created in m2 in m3 nothing is displayed, the following alarm appears:
“Could not read project from project.qpproj.”

I am very sorry for the time involved but really this problem has been difficult for me to solve. I hope you understand me.
thank so much

  1. Create a new empty project in 0.2.0m3
  2. Open and run Pete’s script from within that project
  3. In the pop-up window, target the old 0.2.0m2 project
3 Likes

Now it is possible to visualize our project !!!
Thank you very much for your help and time.
Carolina

1 Like