How can I remove a core Fiji JAR from my update site?

imagej
plugin

#1

Hi *,

I found one related topic on forum: Update sites shadowing core JARs breaking Fiji
But in that case @ctrueden seemed to have performed some magic to solve it.

Here my problem: On an update site I have unfortunately some versions of core IJ2/Fiji packages. This was, because at the time I uploaded, these where versions not yet shipped with Fiji. By now the opposite is true and the versions on my update site are actually old – and worse even – break some Fiji functionality.

I am now stuck since I cannot find a way to remove those files. I can uninstall them, but without them Fiji would simply not start any more, giving me no chance to mark them obsolete on my update site.

I do know about all the classical issues of not being able to remove files from an update site while also updating something (either down or up)… so I think it is not that simple.

Happy for any hint,
Florian

PS: sweet would be if I could just ftp or smb on the update site and remove the files in question… is anything like this possible??? @ctrueden???


#2

See also:


If even if it was easy, you shouldn’t do that, because the updater saves information about previous versions of all files in the db.xml.gz such that client installations can determine if they need to update the file (if it corresponds to an older version), or label it as ‘locally modified’ (so if you did some legitimate local changes, it should not overwrite them).

Maybe that’s a complicated way of doing it, but did you try removing/deselecting your update site? Then the versions from the Java-8 update site get installed, and if you re-select your update site, you can set the file as obsolete?


#3

Hi Imagejan,

yes, I do know about this… but currently the alternative for doing it ‘manually’ is desperation… :wink:
I cannot find a way to get rid of dependencies such as scijava-common.

Your idea was great and straight forward… tried it right away… but:

Still, I thought ‘Keep as-is’ and then marking it obsolete after restart might just work. Unfortunately the updater would not let me NOT install the old versions since they are marked as dependencies of others on that update site.

I know that (in the past?) one could edit the text area to the right and I would have simply removed all dependency entries of scijava-common et al, but in the latest version (on Mac) I was unable to edit the text-area. (Maybe because I’m in ‘install mode’, not in ‘upload mode’, which is the typical source of confusion with the updater we have.)

Ergo: I’m still clueless of how to maneuver myself out of this misery… :wink:

Any help still very much appreciated.

Best,
Florian


#4

Note that downloading and uploading changes are exclusive in the updater.

You’ll first have to resolve the pending changes, in this case marking all the files as Keep as-is, before the updater offers you the option to Mark obsolete (Tr2D):

Does that help at all? Or am I missing some peculiarities of your situation?


#5

Arggghhhh!!! @imagejan, thank you so much for your help.
Everything you said was clear to me already, but without your answers I would never have found out the obvious (and embarrassing)… :blush:

For a non-obvious reason the user credentials on the Tr2d update sites got lost and… who would have guessed… without them ‘Mark obsolete’ is not an option… :wink:
Ergo: the solution is to have a user be given for the update site in the corresponding dialog.

Yes, I feel stupid… but also lucky that it works now.
I think the updater does all the right things, but all in such a non-obvious way… anyways. Fiji is great. Thanks! :smiley:

Best,
Florian


#6

What a waste of time then… :stuck_out_tongue:

Glad that it works for you now! :slight_smile:


#7

Nah, still informative for others who come across this thread!

Glad you figured it out.

PRs welcome! :stuck_out_tongue_closed_eyes:


#8

Not at all… the second half of the sentence made all the difference didn’t it? :wink:


#9

Of course there are plans… :smiley: