How can I have Results (table) reporting length in mm

I’m using the Straight Line tool to measure some distance in my image. The Results (table) is reporting the length of my straight line in pixels, I think. How can I change the settings so that the Results (table) will report the length in millimetre?

Have you tried setting the pixel size correctly in Image->Properties? If you set that in mm, I think the results table will use that unit of length.

If you do not know the pixel size, there is no way for FIJI to tell how long your line is except in pixels.

Thanks for mention Image > Properties. Before post my question, I used Analyze > Set Scale.

The screenshot above show what I’m observing in my machine. I have 1 pixel set to 0.01mm. I zoom the image to see the pixels and used the Straight Line to measure 1 pixel. In the Results (table), I have the length as 0.938. This is why I’m assuming that ImageJ is providing the length in pixels instead of mm.

Any advice on this? Thanks!

1 Like

Not sure what to say, I was able to set the properties to mm (assuming I clicked OK the first time to apply them), then create a line, then measure it, and it worked as expected.


Not sure why it would be different in your case unless you maybe created the line before setting the properties.

1 Like

@Research_Associate, Thanks for the reply.

I think I understood what is happening.

If I use Alt+M, ImageJ will report the length in pixels. If I use Ctrl+M, ImageJ will report the length in mm (or the unit specified by the user when setting the scale).

The very confusing thing is that ImageJ will use the same Results window to report the length in two different units. I would like to have the header of the Results table saying “Length (pixels)” or “Length (mm)” to avoid users interpreting the data wrongly. Can I have a mentor to sent a pull request?