Hessian-based analysis problem in SNT

imagej
windows-10
snt

#1

I’m having issues enabling Hessian-based analysis in Simple Neurite Tracer. Everything works just fine without it, but when I select “Hessian-based analysis” it progresses to “calculating Gaussian” but then seems to get stuck in a loop “WAITING_TO_START_PATH.” It never progresses to choosing sigma, and it doesn’t open the window (even if I click the “visually” option). While it’s forever waiting to start a path, the searching function between two points works fine, but it never progresses to the point of accepting the path or creating the path in the path manager. After this, I have to restart the plugin in to get it to trace paths properly. I’ve attached console screenshots for clarity.


#2

Welcome to the forum @kayhendii!

I’m not able to reproduce this:

  1. Are you subscribed to the Neuroanatomy update site?
  2. Are the Sigma/multiplier values reasonable? (On the Hessian panel, you can click on Choose visually to inspect current values)
  3. Is the voxel separation in Image>Properties… what you expect?
  4. Are you tracing on the Legacy 3D viewer?

#3

Hi @tferr! Thanks!

Sorry for the delay in replying…

  1. Yes I am.
  2. When I select Choose visually it deosn’t bring up the paneled image to inspect the values. Instead, it selects a starting point for a new path. If I try to click on the image again, it connects those two points. At this point it gets stuck “waiting to start path.” It doesn’t bring up the option to save the newly created path, it doesn’t show the path in the Path Manager window, and it still doesn’t show the different sigma options. If I exit the plugin it still shows up in the console as “waiting to start path.”
  3. Yes.
  4. Hmmmm I’m not sure. I don’t think so?

When I initially reported this, I was using Windows 10. I’m able to use SNT with Hessian-based analysis (and Choose visually) with no issues on Linux Mint, but it would be nice to get this worked out in Windows 10 too so other lab users have access to it.


#4

Thanks for the details. I use linux also. Will try to find a Windows computer to see if I can reproduce the issue.


#5

@kayhendii,

Unfortunately, I cannot reproduce this on either Windows 7 or Windows 10 in an up-to-date Fiji installation subscribed to the Neuroanatomy update site. The only bug I can trigger if I click erratically in the paneled image is that the “Choosing Sigma” label may linger even after the paneled image has been dismissed. But AFAICT, albeit distracting, that seems to be innocuous.

Not so sure what to do at this point. Can you please try this and let us know what happens:

  1. Click on the “Cancel/Esc” button to ensure there is no ongoing operation in the background. The button bar should say Click somewhere to start a new path
  2. Click the “Visually…” button in the Hessian Panel. The button bar should say Click on a representative structure and a “Choosing Sigma” label should appear on the traced image’s upper left corner
  3. Click on the traced image (with multi-channel images, ensure the active channel is the one being traced).
  4. IJ’s status bar will report Calculate Hessian eigenvalues at each point. Then, the Sigma wizard should pop-up in the center of the screen.

#6

Hmmm I still have the same issue where I’m stuck “waiting to start path.” Since you were unable to recreate this problem in Windows, maybe this is indicative of a different problem outside of SNT/Fiji. I’ll poked around a little more and see if I can figure out what the cause of the problem is. Thanks for all your help on this!