Help with installing/running Cell Profiler on OS 10.4.11



Hi there,
I hope someone can help me sort out my problem. I can not seem to run Cell Profiler on my Mac. I have a PPC running OSX 10.4.11 and every time I try to run Cell Profiler I get the following message:

"Last login: Wed Feb 11 15:33:57 on ttyp1
/Applications/CompiledCellProfilerPPCBugfixFINAL/CellProfilerForPPC.command; exit
Welcome to Darwin!
crushed-cherry:~ lara$ /Applications/CompiledCellProfilerPPCBugfixFINAL/CellProfilerForPPC.command; exit
name /Applications/CompiledCellProfilerPPCBugfixFINAL/CellProfilerForPPC.command
2009-02-11 15:34:23.322 open[359] No such file: /Applications/Utilities/
Fatal error loading library /Applications/CompiledCellProfilerPPCBugfixFINAL/MCR/v76/bin/mac/libmwmclmcr.dylib Error: dlopen(/Applications/CompiledCellProfilerPPCBugfixFINAL/MCR/v76/bin/mac/libmwmclmcr.dylib, 9): Library not loaded: /usr/X11R6/lib/libXext.6.dylib
Referenced from: /Applications/CompiledCellProfilerPPCBugfixFINAL/MCR/v76/runtime/mac/libmwhg.dylib
Reason: image not found
[Process completed]

Based on some of the previous posts relating to a similar problem for another user it occurred to me that this may be related to X11. I tried to download X11 but I got a message saying I had newer software and therefore could not download. This prompted me to think I had an incorrect version, so I tried to download X11 1.1.3 but I get a message stating there is no need for this software…When I go into Applications > Utilities, I see no evidence of X11 there. I find this very confusing. I am very new to this program so I apologize for my rather basic and general questions but if you an help me it would be greatly appreciated as I am quite eager to try this program.



Hi lodonnell,

Certainly it appears that X11 is not where CellProfiler thinks it is. It should be installed in Applications>Utilities, but if you use Spotlight or just search in Finder does X11 (the application, not a folder named X11 that may reside in the CellProfiler MCR or various locations in Developer) appear anywhere else? It’s possible it was somehow installed somewhere else. In this case, if you move it to Applications>Utilities, CellProfiler should be able to find it.

Now, we have had issues with people whose X11 seems to be in order, but CellProfiler still does not work on OS 10.4. In this situation, we’ve found re-installing X11 from your Tiger DVD to be the only solution (since as you notice, trying to download it doesn’t work).

Let me know if that helps,


Dear Kate,

Thank you very much for your help. So when I use Finder to search for X11 I do not see an application called X11. There is only a Folder named X11 like you mentioned.

So am I understanding correctly in that I need to reinstall this from my tiger DVD?

Thank you so much for all your help, I really appreciate it as I hope to resolve this soon.




Yup, installing from the Tiger DVD should work. X11 is not installed by default when you install Tiger, but you can install it later from the “Optional Installs.mpkg” in the Tiger Install DVD.