Help with Human Cells

cellprofiler

#1

Hello,
I’m new to CellProfiler and I’m investigating its capabilities with some images from our lab.
I understood the organic of Cell Profiler Software, but the difficult part looks to be the customization of each module to our Images (and also try to define a standard method of acquisition).
I’m interested to perform live Human Cell Image Segmentation.

I runed your Example Pipeline for human cells in our images, but it didn’t work so well. I think, probably I’ll need some smooth filter or maybe not. Please take a look.
The original Image


Here are the results with your pipeline.
The big change happens when I changed the typical diameter of objects in Module “IdentifyPrimaryObjects”. It Identifies to many edges in both cells and nucleus.
I’m using a range of 80, 130 pixels for nuclei objects.

test3.cp (8.65 KB)

Best Regards,
Ricardo M.
Results.zip (1.37 MB)


#2

Hi Ricardo,

It looks like the thresholding method in IdentifyPrimaryObjects is not appropriate in your case. I would suggest changing it to Otsu global; using 3-class instead of 2-class thresholding with the middle class set to background will give you better results as well. Also, you can try the following:

  • Uncheck the “Try to merge…” setting
  • Your typical diameter size seems to be too small; you can check this using Tools > Measure length
    from the menu in the module display window. A typical nucleus seems to be ~170 pixels so I would set this to 130, 300. - Check the “Automatically calculate smoothing filter size…” setting.

For IdentifySecondaryObjects, since your cells are highly confluent and the borders aren’t terribly clear, you can try using Watershed - Gradient to get somewhat better result than with Propagation.

Hope this helps!
-Mark


#3

Thank you Mark,

It just worked :smile:

Best Regards,


#4

I have another situation to solve: I applied this pipeline to similar images, but in some images it cannot distinguish between two objects (nucleus) in a very close position.
What parameter(s) should be adjusted?

In this case of assays, there’s a channel for each object we want to identify?
For example, the red channel is (always) used for identify cell shape/cytoplasm whereas both blue and green for the nucleus?


Best Regards,


#5

Hi Ricardo,

The two nuclei that are not getting segmented seem to be saturated in intensity and hence the “Intensity” setting for declumping doesn’t work as well. However, changing it to “Shape” for both declumping and division seems to do the job provided that the image is pre-processed beforehand. I’ve attached a pipeline which includes an EnhanceOrSupressFeatures module that helps a bit; the filter size should be set to roughly the typical diameter of a nucleus. Also, I’ve included a Resize module to save memory since your images are much larger than needed for this purpose.

I think part of the reason this is occurring is that some of the nucleus are saturated by over-exposure. If possible, you may want to lower your exposure to avoid this. If you do so, the Intensity declumping settings should work.

Regards,
-Mark
2011_03_12.cp (9.7 KB)


#6

@mbray @Ricardo

Hi, I am new to cellprofiler too, and I would like to know if the Human Cells pipeline accepts bright-field images?


#7

Hi, Unfortunately that will not work on bright-field images you have to change the pipeline according to your experimental needs. For bright-field images you can first add thresholding module to detect objects from the background following IdentifyPrimaryObjects module. Let me know if that helps

Regards
Hamdah