Help regarding dark background option in macro

Hi everyone,

I come asking for your help, I cannot find the command line in the macro that would allow me to uncheck the dark background option in the threshold settings.
ef

When I uncheck the option while recording a macro, nothing appears.

Thank you in advance for your help !

Théo.

HI @Theoporosite,

That option corresponds to the word “dark” in the parameter string. To make it appear in the record, you have to hit Auto after uncheking that box (or changing the automatic threshold method), which will record:

 setAutoThreshold("Default dark");
setAutoThreshold("Default");

Cheers!
Nico

1 Like

Hi Nico,

Thank you for your reply, I could not see the line appearing in the macro because I had not opened any file…I should be more careful next time.

Thanks for your time !

1 Like