Help needed to set up Leica DMI4000B with micromanager

I am trying to set up a Leica DMI4000B microscope (and an Andor camera) with micromanager (to perform some SRRF imaging eventually). I am facing several issues and hopefully someone can help (I don’t know how to code unfortunately).

I was able to follow the instructions on this page: https://micro-manager.org/wiki/LeicaDMI and instructions from Andor to connect the microscope and camera. The only step I skipped is that I didn’t install [Media:Leica-USBDriver.zip] since micromanager can “see” Leica microscope and I believe similar driver has been installed previously (the microscope has already been connected to the PC through a USB cable and can be access using another software).

Everything works fine except for two issues now:

  1. I can run one-color time-lapse through MDA and the auto shutter is working fine. The shutter is closed between acquisition intervals as expected. However, when I run multi-color time-lapse through MDA, auto shutter is not working properly. The shutter will remain open during the acquisition intervals (I am using “IL shutter” as the “core-shutter”). My feeling is that after the first set of acquisitions for channels 1&2, at the beginning of the acquisition interval, the fluorescence filter turret will move back to the location for channel1 (prepared for the next set of acquisitions) and this turret move activates the IL shutter.

I have submitted a trouble ticket and also hope to get further help from this forum.

  1. My second issue is on how to control the transmitted light. I tried “TL-shutter” but it is unresponsive. Some early posts stated that Leica DMI4000B actually doesn’t have a “TL-shutter”. Can anyone confirm on this?

Thank you very much for your time and help.

It looks like the trouble tickets are no longer making it to us after our latest server updates/migration. I’ll look into this, but feel free to email me the report directly to speed things up a bit.

Problem Report.txt (120.8 KB) MMConfig_EMCCD_Leica.txt (6.3 KB)

Thank you very much, Nico. Please see below the attached problem report and configuration file. Thank you so much for your help.

  1. Some stands are configured to open the shutter after changing the ‘method’. You might try removing Method from your channel group to see if that helps.

  2. According to the Leica brochure, the transmitted light shutter on a DMI4000B or DMI6000B can be either manual or motorized. If it is motorized, I think you should be able to control it from the buttons on the left side of the microscope stand (one button switches state between controlling the TL and IL shutters). If that doesn’t work, it probably won’t work from software, either.

I would also remove the “AutoShutter” from your channel group. This property is usually set manually before running the acquisition. Setting it in the channel presets may lead to strange shutter behavior.

Thank you very much for the quick response.

  1. Unfortunately, removing “method” and “auto shutter” from the channel group didn’t improve the problem. I am attaching the new MMConfig_EMCCD_Leica.txt (6.0 KB) Problem Report2.txt (119.8 KB) problem report and configuration file.

  2. I can press one button on the left side of the microscope stand to toggle between TL and IL. However, I can not use micromanager to control the state of the TL shutter. If I switch it from “1” to “0”, I will get an error message saying that the response is longer than 5s.

Thank you very much ahead of time for further help.

Btw, even if I run two-color imaging (1 time point only), after the whole process the IL shutter is left on. I assume that the sample should be left in dark after the experiment if all things are working properly.

Hi Nico,

Do you have any suggestions in addition to removing “AutoShutter” and “method” from the channel group?

Thanks

When you set the Core-Shutter to “TL” and press the shutter button on the front MM window (after unchecking autoshutter), does it respond?

As for issue 1: Indeed, the code opens the IL shutter at the very end of the acquisition. However, when you start the acquisition, the IL shutter is open as well! Normally, you would start an acquisition with the shutter closed and autoshutter on. You have the shutter open and autoshutter on. This should only happen when you are running live acquisition (or are snapping an image), and I do not really understand what could cause this. I would investigate the starting situation a bit more, and try to find a way that the shutter is closed before you start acquisition. The Acquisition Engine tries to restore the situation to what it was before you start the acquisition, so it is doing the right thing (although it is not would you want).

Feel free to post another Problem report following unchecking autoshutter, opening and closing the shutter with the shutter button, and re-checking autoshutter.

Thank you very much.

Toggling the shutter button options can fix the issue with 1 channel time-lapse. After time-lapse, the shutter stays closed.

However, the shutter issue remains when doing two channel MDA. I have set the shutter to be closed when I started the time-lapse imaging. Please see my error report below.
Problem Report3.txt (276.9 KB)

I am not sure whether this is related: when the IL-shutter is closed, if I manually switch the filter cube, the shutter will be spontaneously open after this switch. I am not sure whether this is related to my issue with MDA.

Yes. The shutter can respond to the button when the Core-Shutter is set to “TL

Please see my full problem report above [Problem Report3.txt].

My feeling is that after the first set of acquisitions for channels 1&2, at the beginning of the acquisition interval, the fluorescence filter turret will move back to the location for channel1 (prepared for the next set of acquisitions) and this turret move activates the IL shutter.

Your problem report 3 says that the IL shutter is closed at the end of the acquisition. MM sends a command to close the shutter (on line 6721) and the microscope body acknowledges the command. The end of the report shows the state of the IL shutter as 0 (closed). Are you saying that it was open?

I have to confess that I always disliked the firmware on the Leica bodies trying to do “smart” things that the computer code has to work around…

  1. MDA acquisition/shutter issue

Problem Report5.txt (123.8 KB)

Thank you very much for your help, Nico.
My report 3 is confusing, since I operated both MDA with two channels and then MDA with one channels. MDA with one channels has no shutter issue. Please see above the attached new report 5.

I tried to read the report. It seems to me that indeed Micromanager first set the “IL-Turret” after the first set of acquisitions (at the beginning of the interval waiting), and then an acquisition sleep was implemented. Unfortunately, the Leica microscope implements an automatic shutter on after each IL-Turret change. Do you see a possibility to fix this issue? Or is it possible to impalement acquisition sleep before setting “IL-Turret” in micromanager?

Thank you very much


2020-08-15T11:43:11.267422 tid9624 [dbg,Core:dev:IL-Turret] Will set property “Label” to “2-GFP”

2020-08-15T11:43:11.267422 tid9624 [dbg,dev:COM5] SetCommand -> 78022 2\r

2020-08-15T11:43:11.267422 tid9624 [dbg,Core:dev:IL-Turret] Did set property “Label” to “2-GFP”


2020-08-15T11:43:11.285375 tid9624 [dbg,App] [AE] acq-sleep

  1. TL-shutter issue

Do you have any further suggestions on the TL-shutter issue? Thank you

Hi Mark,

Please see the discussion/information below. Do you have any further suggestions?

Thank you very much ahead of time for your help.

Hi Nico,

Please see my posted new report #5 above.

Is it possible to implement acquisition sleep before setting “IL-Turret” in micromanager?

This thread is becoming very confusing. I am not quite sure what I am responding to anymore. I will focus only on issue #1, if #2 is still a problem, probably best to open a new thread for that one.

I agree that the major problem appears to be that the microscope opens the shutter whenever you move the IL-turret. That seems a bit of a ridiculous thing to do (see my previous comment about microscope bodies trying to outsmart their users). One wild guess: Your logs show that the TL shutter is always open (state 1). Can you ensure that it is closed (state 0) before moving the IL-turret? There must be a way to move the turret without the shutter automatically opening. You may want to ask Leica for help with this.

I just want to let you know that the issues have been mostly fixed, by configuring through the Leica Hardware Configuration SDK. The FL shutter behavior after turret moving can be set up there. I still cannot control the TL-shutter, but my microscope might not have such shutter. I can now use the TL-light as the shutter for acquisition (of course it is slow). MDA is behaving OK (except for that transmission would take ~ 2s due to the slow response of the TL-light).

MDA still has one issue though: if numbers were previously put under “Time”, “# of acquisitions”, “intervals”, these numbers still function even when “Time” is not selected. Is this a bug of the software itself?

That bug is now fixed (it was present in nightly builds between July 27th and ~August 25th).