HELP ASAP PLZ Bio-Informants Not Importing in Image J

I tried importing an MP4 into Image J using the Bio-informant plugin because this one website told me I had to. When I tried doing it, a box popped up that said there was a problem with the importing. Then, the following code or words came up:

loci.formats.MissingLibraryException: QuickTime for Java is not supported with a 64-bit JVM. Please invoke the 32-bit JVM (-d32) to utilize QTJava functionality.
	at loci.formats.gui.LegacyQTTools.checkQTLibrary(LegacyQTTools.java:336)
	at loci.formats.in.LegacyQTReader.initFile(LegacyQTReader.java:142)
	at loci.formats.FormatReader.setId(FormatReader.java:1392)
	at loci.formats.DelegateReader.setId(DelegateReader.java:300)
	at loci.plugins.in.ImportProcess.initializeFile(ImportProcess.java:499)
	at loci.plugins.in.ImportProcess.execute(ImportProcess.java:142)
	at loci.plugins.in.Importer.showDialogs(Importer.java:140)
	at loci.plugins.in.Importer.run(Importer.java:76)
	at loci.plugins.LociImporter.run(LociImporter.java:78)
	at ij.IJ.runUserPlugIn(IJ.java:240)
	at ij.IJ.runPlugIn(IJ.java:203)
	at ij.Executer.runCommand(Executer.java:150)
	at ij.Executer.run(Executer.java:68)
	at java.lang.Thread.run(Thread.java:748)

Please give me some help!!! I need an answer ASAP so I can complete my research and data analysis. I essentially just have to import the MP4 files before doing anything else.

Dear Nit,
even if I don’t like too much the people that jumps in a public forum with ASAP, since everybody here has some research and some data analysis to finish…
For avi, mp4 and not biological file formats one solution that has always worked for me is the FFMPEG plugin.
You can install it in Fiji (https://fiji.sc) with its update site called ffmpeg.
https://imagej.net/Video

Then relaunch Fiji and you will have it in the menu File-> Import -> Movie (FFMPEG), use it to open your mp4 file.

I just tried with this mp4 sample:

it works

have a nice day,
Emanuele Martini

3 Likes

As recommended above I would also suggest using the FFMPEG plugin for MP4 files

1 Like