H2AX spots relationship with nuclei may couse problem

Hello,
I am trying to find out how to correctly setup the pipeline and export it to database. It seems that CP does not correctly relate H2AX spots to their nuclei in my setting. If I test the pipeline it looks OK - there are around 2-3 foci per nucleus (~100 nuclei and ~250 H2AX foci per image) but after analysis in CPA - it shows around 150-200 foci per nucleus. The total number of H2AX per well as calculated from several images per well seems to be correct. In export to database module it shows warning that “H2AX_spotsAll is not in 1:1 relationship with other objects …”… but I don´t know how to set it differently or if it causes the problem I am describing.
See the images and the pipeline for possible wrong setup.

Eventually, do you have by chance a model pipeline (which I can adapt to the sizes and intensities of my images) that is designed to count how many H2AX spots per nucleus exist ? I am comparing numbers in individual wells in 96 well plate.

Thank you very much.
HF_H2AX_re.cpproj (657 KB)












In ExportToDatabase, I would recommend two things:

  • Do not export all object measurements to the database. If you interested in the per-nuclei foci count, then export the cell measurements only. Select “Select…” for “Export measurements for all objects…” and then select “Nuclei” from the list-box that appears.
  • Given the above, if you want to examine the per-nuclei foci counts, then you will want to plot the Nuclei_Children_H2AX_SpotsAll_Count measurement.

Regards,
-Mark

Hi,

The ExportToDatabase warning is the key issue. You have two object types: Nuclei and H2AX_spotsALL. The problem is just as the warning says, namely that there is not a 1:1 relationship between these objects. So that, if you export your objects to a SINGLE object table, there will be some rows that have NULL values.

For example: If you have one nucleus and 3 H2AX foci in an image, you will have, in your Per_Object table, something like this below:

[quote]ImageNumber Object Number Measure1Nucleus Measure2Nucleus, Measure1H2AX, Measure2H2AX, …
1 1 6 4 5 6, …
1 2 NULL NULL 6 7, …
[/quote]

because ObjectNumber=1 will refer to BOTH the first Nucleus and the first H2AX spot. But the second nucleus doesn’t exist, but since there are more H2AX, then NULLs (or possibly zeros) would have to fill in the gaps. Sorry, I have a feeling I am not explaining this very well!

In any case, having said all this, you should change the setting that is giving you the warning to output to multiple per_object tables. This will output 2 distinct tables for your objects with no gaps or NULLs needed. The Per_Nucleus table will have many fewer rows than the Per_H2AX table. The counts of children objects (H2AX) from RelateObjects will be contained in the parent’s table, called Per_Nucleus. Make sure that you load up that table in CPA and I think you should be all set.

Let us know how it goes.
David

Thank you, selection of “nuclei” as only object in “Export measurements for all objects…” menu solved the problem and now the “warning to output to multiple per_object tables” disappeared.

Good!
-David