Grid/Collection Stitching Plugin Gives Array Out of Bounds Error

hello, we are trying to stitch two 3d tiff stacks (“tiles”):

tile 140 should be above tile 1

but no matter what inputs we try, we keep getting an out of bounds error when using a position file the grid stitcher. we tried two tiles, four, and 140 tiles. we tried relaxed and stringent displacement thresholds, we tried different signs of the tile offsets in the position file. nothing helps. also the PC has 64GB of ram, and when we look at the task manager, its not a resources issue.

finally, the pairwise stitcher is able to stitch these two stacks perfectly (see pairwise_fused.tiff). so it appears that there is some error in the grid stitcher. please help. thanks!

Hello @iomega15, and welcome to the forum!

Sorry that this post has been unanswered for a while. I just had a look at the tif files you linked, and it seems that when opened with Bio-Formats (which is what the stitching plugin uses internally as well), the stack opens as a 1-slice, 147-frames stack, so it is seen as a 2D time-lapse movie. This explains why you wouldn’t be able to apply a 3D translation model to the image.

Can you try re-saving your image with Plugins > Bio-Formats > Bio-Formats Exporter after correcting the dimensions in Image > Properties…?

Let us know if that helps solving your issue.

What software did you use to write those files? I wonder if the dimension metadata got lost at some point after acquisition during your pre-processing.