Green and blue channels giving the same intensity

Hi,
I have a pipeline I had converted from the previous version of CellProfiler, and now when I run it, the green and blue channels are giving me the exact same numbers for intensity. I can open the file in ImageJ and see that the channels are different. I’ve uploaded an image set and my pipeline. Please help!
-Anne





Upon further attention, I realized all of the channels are giving the same intensity number. If I split the image into individual images, I get the correct intensities. I would prefer not to have to do that, since it would greatly increase the number of files I have. Any idea what the issue is?
-Anne

Hi Anne,

This fix should clear this up. Would you try a new trunk build? github.com/CellProfiler/CellPro … TrunkBuild

Thanks,
Mark

Hi Mark,
The most recent trunk build for windows is from two days ago, so would it be fixed in that version? I installed the new build, and now I get the following error:

Traceback (most recent call last):
File “cellprofiler\pipeline.pyc”, line 1932, in run_image_set
File “cellprofiler\modules\namesandtypes.pyc”, line 1070, in run
File “cellprofiler\modules\namesandtypes.pyc”, line 1109, in add_image_provider
File “cellprofiler\modules\namesandtypes.pyc”, line 1128, in add_provider_measurements
File “cellprofiler\modules\namesandtypes.pyc”, line 1725, in provide_image
File “cellprofiler\modules\loadimages.pyc”, line 3205, in provide_image
File “bioformats\formatreader.pyc”, line 785, in read
UnboundLocalError: local variable ‘metadata’ referenced before assignment

I don’t even have metadata, so I don’t know what this is referring to. I uploaded my pipeline again since I had made some very minor changes since the last one I uploaded (mostly renaming some images).
-Anne

The build with the fix might not have completed when you downloaded it. Give it another try from the same page; the current build should be from March 13,2014 or newer.
-Mark

That seems to have done it. Thanks Mark!
-Anne

This issue has been addressed with the 2.1.1 release.
-Mark

Hi Mark,
I downloaded 2.1.1 (partially because I had my computer repaired and lost the trunk build I was using) and I am now having the exact same issue again. I’ve attached my pipeline and a sample set of images.
-Anne





Hi Delenn,

I gave your pipeline a try with your images and it ran with no errors. Did you install 2.1.1 on top of the trunk build, or some other prior version? If so, you may want to try uninstalling 2.1.1, deleting the installation folder (if it exists) and then re-installing.

Regards,
-Mark

Hi Mark,
I had uninstalled the previous version before installing this version. I do not get an error message, just the intensities are the same across every channel (the red image seems to be the only one being measured).
-Anne

Hi Mark,
Is it possible to get the file for the trunk build from March 13th (for Windows 64 bit). I lost the install file, but that build was working perfectly for me and my analysis is halted until I get something that works.
Thanks,
Anne

Hi Anne,

The closest one I could find was from May. But give it a try (I assume you have Windows 64?):
broadinstitute.org/~dlogan/C … 123723.exe

David

Hi David,
Thank you. But unfortunately I’m still having the same issue with that version.
-Anne

Hi Anne,

OK, I took a look at your images (finally!). Let me see if I understand correctly and this may solve your issue and you can hopefully use the 2.1.1 release CP. Your D3D image is what you call “Deconvolved”, and I inspected the image in the tool FIJI (Fiji Is Just ImageJ) and it is a true RGB TIFF. No problem. Your R3D image however is considered a TIFF Stack (you can see the difference in CP if you extract Metadata using the header information - the R3D appears as 3 individual monochrome channels within one file, but this is even more clear if you inspect in FIJI) . And as such, it would need to be loaded specially (see Loading Image Stacks and Movies).

BUT before you do that, do the R3D and D3D images have the same information? They look very similar to me and perhaps you deconvolved one of these prior to CP? If so, you could just remove the D3D and stick with the R3D, no? However, if there really is different info in these, then you could have a somewhat complicated NamesAndTypes and also remove one of your ColorToGray modules (I disabled it). See my attached modification to your pipeline, and see if it helps.

Finally, we don’t have that trunk build from March 13. We build a lot and don’t save all of them after awhile. This should be solvable though with the current incarnation!
Let us know how it goes,
David
Bacilluspipeline073014_DLmod.cppipe (102 KB)

Hi David,
Thanks for the help. When I try to run the pipeline it says I do not have any valid image sets. I think the easiest thing for me here is to just split the images and load them individually. Is there a reason why the program stopped dealing with the image stacks in the colortogray module? The only reason I had it set up this way is because using the version I first created the pipeline in this was not an issue at all. I need the rgb deconvolved image in order to get the best objects out of the images (better lines), but I want unaltered intensities, so that’s why I’m using a nondeconvolved image and I can’t change it to rgb.
-Anne

Hi Anne,

I turned on Metadata extraction which is necessary if you want to process the Stack properly. So in Metadata, you should click both the “Update metadata” button as well as the “Update” button, in that order. Then NamesAndTypes should not complain. (You may need to restart CP first?)

If you mean why did I disable the ColorTogray module, it is because Stacks are split into grayscale images in NamesAndTypes using info from Metadata. I can see that this is a little confusing, but CP has to deal with more and more complicated range of images types (grayscale images and multi-plane tiffs interleaved in various ways, RGB, movies, etc!).

That makes sense - I was just hoping for a simpler solution. But either using my pipeline or splitting out the tiffs pre-CP should both work.

-David

I was also facing the similar issue but new version solved my problem.