GC overhead with 2.2.1

cellprofiler
gcoverheaderror

#1

Hi there,

I’m getting a GC overhead limit exceeded when clicking on the Update button in NamesAndTypes for 576 images (96 well plate, 6 images per well). This only happens with the CP 2.2.1 version, not with the 2.2.0 version (on an older and weaker computer). I’ve also increased the memory for java in preferences, but the error persists. It’s a clean installation on a new computer (Ubuntu 16.04). Are there any underlying packages (e.g. cython, numpy etc) that need to be installed in a specific version?
Is that something known for the new version? Or do I have to move to the LoadData module (even though it works fine in the older version)?


#2

Have you verified it’s happening on old vs new computer on the exact same image set?

In any case, work is happening RN on making sure to pin the right versions of all the underlying packages for 2.2.X- you can follow this GitHub issue for more information.


#3

It loaded in 2.2.0 (new computer) but threw an error in the MeasureObjectSizeShape which seemed to be related to numpy and h5py (list indices must be intergers, not tuple). So I tried to install the same package versions as on my old computer, but there were clashes, so I moved to 2.2.1

Thanks for the github link. I’ll re-check my versions

Update: I fixed it somewhat by using the Oracle JDK instead of the Open JDK. Still quite slow in updating though. And this only works for the 2.2.1 version.
I have now installed the 3.0.0 (from the github master branch, sudo -H pip install --editable .) and although there is no error that pops up, the terminal indicates a Java heap space error:

      File "/usr/local/lib/python2.7/dist-packages/javabridge/jutil.py", line 852, in fn
    raise JavaException(x) 
javabridge.jutil.JavaException: Java heap space

and therefore doesn’t load/update the metadata… any ideas?


#4

Can you make a GitHub issue for that? Thanks.


#5

Java GC overhead limit exceeded CP 3.0.0 Ubuntu 16.04 #3492