From cluster with matlab to cluster without matlab

cellprofiler

#1

HI,
I have to switch from the batch processing in cluster with matlab to the one without matlab, because few nodes in my cluster have matlab license.
My setup for the batch mode with matlab work perfectly.
So, I changed the batchrun.sh file (and seems correct), and in the pipeline I just switch from “MATLAB” to “compiled” option in the firts choice of the CreateBatchFiles.
module. I checked that my cluster, orchestra.med.harvard.edu, has installed CPCluster in /opt/CPCluster.
All the batches start well, but then they interrupt and an error appears in the LoadImage module.

Exited with exit code 255.

Resource usage summary:

CPU time   :      1.67 sec.

The output (if any) follows:

Warning: Unable to open display , MATLAB is starting without a display.
You will not be able to display graphics on the screen.
??? Error using ==> LoadImages
Image processing was canceled in the LoadImages module because an error occurred when trying to load the first set of movies. Please check the settings. A common problem is that there are non-image files in the directory you are trying to analyze, or that the image file is not in uncompressed avi format. Matlab says the problem is: Index exceeds matrix dimensions.

Warning: Could not find appropriate function on path loading function handle C:\Dokumente und Einstellungen\luca\Eigene Dateien\software\CellProfiler\CellProfiler_1.0.5122_XP32\CellProfiler_1.0.5122_XP32\CellProfiler_mcr\CellProfiler\CellProfiler.m>LoadPipeline_Callback
<<<<<<<<<<<<<<<<<<

Do you have any idea what is going on?
Should I change something else in the modules?


#2

Hi,

It looks like CPCluster is looking for its functions/modules in the wrong place. I assume “C:\Dokumente und Einstellungen…” is not the location of your cluster’s CellProfiler.m file. But everything worked OK when you had MATLAB as the option in CreateBatchFiles (except for too few Matlab licences)? That’s strange.

Did CPCluster compile without errors? It also may be that the path to your MCR files is incorrect. Ensure that these directions are followed (the script run_CellProfiler.sh that is created after compilation tries to set these automatically): mathworks.com/access/helpdes … ame=Search

Apologies that we didn’t get back to you sooner.

Let us know if this helps,
David