FPBioimage blank after update

Hello,
I have updated OMERO.web from 5.6.3 to 5.8.1 and at the same time updated all the plugins. When loading an image using FPBioimage in OMERO.web the page does not load the image. It shows the FPBioimage header and footer. When I opened the console to check for errors I get this message:

An error occured running the Unity content on this page. See your browser JavaScript console for more info. The error was:
TypeError: fpcanvas is null

Please let me know if there is further information I should provide.
Thank you,
Laura

Hi Laura,
I’m afraid I can’t be much help with any errors coming from the FPBioimage code. The OME team merely package the viewer into an omero-web plugin.
Can you remember what version of omero-fpbioimage you have before you upgraded?
There haven’t been many releases recently, and the last one that changed the FPBioimage code was 0.3.0 (October 2018) see changelog. So it’s possible that you’re still running the same viewer code as before?
In which case, I can only suggest trying in a different browser, or possibly even a full refresh of your current browser?

Do you see the same error with various different images? I wonder if an image is too large and is causing that error.

Sorry I can’t be more help, but please let us know if you can’t get it working.
Regards,
Will.

Hi Laura,
After asking others on the team, it seems that the error could be due to the Image in OMERO. Can you view that Image in the webclient viewer? If not, do you see anything in the browser console logs? (you can right-click on the page and ‘Inspect Element’ to open the Developer tools. Then look in Console or Network tabs).

Will

Hello Will,

Thank you for the suggestions. I have tried Firefox and Chrome and get the same error. I have the same error with different images. I am able to open the images I tested in the webclient viewer, iviewer and figure.
This is the Console output from Chrome (Firefox has similar messages)
2021-02-03-110110_553x125_scrot
However, considering what you said about a too large image, I tried opening it via a remote desktop on campus (Safari) and it worked fine. So it appears to be a bandwidth/internet speed issue due to working from home, not an OMERO issue.
Thank you for your suggestions, they really helped me work it out.
Laura

Hi Laura,

It seems that the loading of the image stack is failing, possibly because it’s taking too long and timing out. But it might be another issue.
You could try opening that first failed link 000.png in a new browser tab, which will be like this (where the Image ID is 123):

/fpbioimage/imageStacks/123/000.png

That might give you more info on why it’s failing to load.

Regards,
Will.

Hello Will,

When I tried to open the first failed link I get a 500 Internal Server Error. I checked the Response tab in the Console and it had this message:

Traceback (most recent call last):

  File "/home/admin/omerowebvenv/lib64/python3.6/site-packages/django/core/handlers/exception.py", line 41, in inner
    response = get_response(request)

  File "/home/admin/omerowebvenv/lib64/python3.6/site-packages/django/core/handlers/base.py", line 187, in _get_response
    response = self.process_exception_by_middleware(e, request)

  File "/home/admin/omerowebvenv/lib64/python3.6/site-packages/django/core/handlers/base.py", line 185, in _get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)

  File "/home/admin/omerowebvenv/lib64/python3.6/site-packages/omeroweb/decorators.py", line 538, in wrapped
    retval = f(request, *args, **kwargs)

  File "/home/admin/omerowebvenv/lib64/python3.6/site-packages/omero_fpbioimage/views.py", line 149, in fpbioimage_png
    plane = Image.open(BytesIO(jpeg_data))

  File "/home/admin/omerowebvenv/lib64/python3.6/site-packages/PIL/Image.py", line 2862, in open
    "cannot identify image file %r" % (filename if filename else fp)

PIL.UnidentifiedImageError: cannot identify image file <_io.BytesIO object at 0x7fb22d79a150>

<WSGIRequest: GET '/fpbioimage/imageStacks/10403/000.png'>

Thanks,
Laura

Hi Laura,

My only guess is that one plane of the stack might not be rendering correctly. The code is failing where it’s trying to combine a plane into a stitched mosaic to return to the viewer, but I can’t tell which Z-plane it is. You’ve said that the image does open OK in other viewers? I just wonder if you click through the Z-planes whether there is any Z that’s not working? If so, you could maybe try the same dev-tool trick to open the failing image URL e.g.

/webclient/render_image/123/[z]/[t]/

This might give you a more informative error, although it may not help to fix the image.

Will