Fiji updater problem + FLIMJ installation error

Hi Forum,
I have some problems with:
first: update Fiji:
When I go to: “Help > Update” the following window pops up:

Then I click “apply changes” and the following window appears:

2

Any idea how to overcome this problem?

Another issue is installing FLIMJ

When I click “manage update sites” and I check FLIMJ URL I receive following window:

upon clicking “apply changes” I receive once again window:
2

So, I do following - see:

and I click “apply changes”. Then another window appears with the following info:

[ERROR] java.io.FileNotFoundException: C:\Users\MICHAL~1\Fiji.app\update\jars\flimj-ops-2.1.1.jar (System nie może odnaleźć określonej ścieżki)

Bolded text is in polish and indicates that “system can not find the specified path”

I have Win10 Pro. I have Java FX for FLIMJ and I also changed Java version (thank @hinerm for your help).
Thank you for your assistance.
MM

@M_Majko ok, there’s a lot going on here. I’m concerned about the early FileNotFoundException on db.xml.gz.tmp. That file is basically the master record of what’s installed, and it’s not clear to me why there’s a tmp of it (or why it isn’t found)… but if there are problems with the db.xml.gz then I would expect future updates are unlikely to be successful.

Let’s get your core Fiji installation working first before we worry about FLIMJ. Can you try a fresh installation? Just run Help > Update..., update, restart, and repeat until you get the “Your ImageJ is up to date!” notice.

One thought that occurred to me - what version of ImageJ 1.x are you running? You can click on the status bar and get the version:

Hi @hinerm
I tried to update according to path you specified, however still without any effect. I mean I receive a message as shown in my first post, see: first two windows. I did not get a message “Your ImageJ is up to date”.

My ImageJ version is:
ImageJ version.tif (264.1 KB)

In your post you mentioned this file: db.xml.gz.tmp.
In console, next after name of this file, is information in polish that “Access denided”. Maybe it will help… .

1 Like

Well that is not good.

It looks like Fiji is physically located in your user directory? Are there any security restrictions on the directory?

Is this new behavior? Have you ever been able to update Fiji?

A have a new computer in a new job. This is the first time when I try to update Fiji in my new machine. Previously, when I used other computers, usually I had no problems, or at least I do not remember any problems with updating or installing a plugin.
I do not know about any security restrictions.
I tried to uninstall and once again install Fiji. I tried to instal Fiji according to this suggestion:

Caution: " Program Files " not recommended!
If you are installing ImageJ on Windows, we strongly recommend that you store your ImageJ.app directory somewhere in your user space (e.g., " C:\Users\[your name]\ImageJ.app ") rather than in " C:\Program Files " or other system-wide directory. If you move ImageJ.app to such a directory, modern versions of Windows will deny ImageJ write permission to its own directory structure, preventing it from being able to update. See also imagej/imagej#72.

However I also ingnored this recomendation. It both cases with no effect. I always had the same message as shown is my frist post.
I am still determined to fight for Fiji as I really like the software and the idea behind it. Unfortunatelly in my enviroment I do not have any advanced users who might help me to overcome this problem.
Any other ideads how to update?

Ok. success. I asked our faculty computer guy for help and he did some magic over my machine and ImageJ is updated. The problem regarded - as Mark suggested - “security restrictions”. Sometimes easiest and obvious ways work!
Mark thank you for your help. Now I am going to play with FLIMJ.
best and thank
mm

1 Like