Fiji updater and proxy configuration


sitting network-wise behind a proxy I recently faced an issue with the updater in Fiji when some of the sites start to use https. It appears to me that Fiji currently can not properly configure proxies for both protocols in the proxy plugin. The only solutions I came up with is to either specify the proxy configuration on the command line (this is for the Windows platform. Linux is affected the same way - one just just has to adapt the path to the Fiji laucher):

C:\Programs\\ImageJ-win64.exe -Dhttps.proxyPort=2011 -Dhttp.proxyPort=2011

or one could use a groovy script:

System.setProperty(“http.proxyHost”, “”);
System.setProperty(“http.proxyPort”, “2011”);
System.setProperty(“https.proxyHost”, “”);
System.setProperty(“https.proxyPort”, “2011”);

and then run the updater.

Does this all make sense? May be this behavior is partly due to the settings in our proxy server.


Thanks for this post. I had the same problem and this script fixed the issue!

1 Like