Fiji Plugins can not be installed - Trouble with Java?

Hello
I’m new to Fiji and have trouble installing plugins via the “Manage update sites” feature. When running Help → Updates, after the system went through all updates I get the message that there are locally modified files and after dismissing the message and hitting “Manage update sites” the software freezes and I have to force quit it.
I’m running MacOS 11.2.3 with Fiji 2.1.0 and Java 1.8.0_202 (what Fiji shows on startup). When checking in the system preferences for Java I get 1.8.0_281 as Java version.
It might also be noteworthy that ervery time I should get a new window it does open within the existing window which is resized to the new window size.

Any help is appreciated!

Thanks,
Christian