Fiji or Imagej lost menu in new macOS high sierra

Any ideas to deal with it?


Have you tried using latest-greatest Java? Might be apple changed some menu-related API… Does this happen also with other Java apps?

Just for clearification: The menu is not lost in general, right? Sometimes, when the menu disappears, I need to activate the main Fiji window to get it back.

Is that the bug you are referring to?


Thanks, Robert.

This is the issue I met.

Hi there,

Thanks for your reply. I have updated the Java runtime environment but still not working. I just checked the ImageJ, which is same as Fiji.



Hi Weiyan,

by other Java application I meant something completely different than ImageJ/Fiji. I have verified your issue on a fresh install of High Sierra. Indeed, Fiji/ImageJ are missing the menu bar:

however, the issue extends to all Java applications (here CLC Main Workbench):

There are user reports of menu bar issues in Android Studio and other Java apps. So far the only workaround was to install legacy Java 6 ( - though ImageJ2 relies on some Java 8 technology, so some of its features won’t be available when using legacy Java.

I guess you will have to wait for a fix upstream (from Oracle in Java or from Apple in macOS ). If you have upgraded your production system to beta OS - well - you are walking on thin ice here. Good luck.




Hi Radek,

Thank you so much for your suggestion. The old Java 6 works for FIJI in High Sierra.



1 Like

Hi, I tried to start ImageJ with
open /Applications/ImageJ/
from Terminal. Here the menus appear as usual. Seemingly it has something todo with the launcher!


Hi all,
solved menu issue!

you have to download new version of imageJ (multiplatform -

There will be ij.jar, which u can open (with menu)

If u want to have whole app open automator > new > application, then find and click run AppleScript and replace code on:

on run {input, parameters}
set p to POSIX path of (path to me)
do shell script "java -jar " & p & “/Contents/Java/ij.jar”
end run

Save as > imageJ on desktop for example (now u have an app)

show content fo the app and enter contents

create folder java and paste ij.jar, plugins, macros and luts folders.

How to replace an icon u should know :slight_smile:

Hope u will do this easy.

or easier in automator

  1. get specified file from finder -> add ij.jar
  2. open using deflaut app
1 Like


Change true to false at CFBundleAllowMixedLocalizations.


I upgraded to High Sierra today, and I cannot reproduce this issue with a fully up-to-date Fiji on my upgraded system.

(Fiji Is Just) ImageJ 2.0.0-rc-61/1.51n; Java 1.8.0_144 [64-bit]

I tested also with Java 1.8.0_11 and it also did not have the issue on my system.

In order to address this issue, we need more details about the exact circumstances in which it occurs. So if you are still suffering from this problem: please click the status bar in the main ImageJ window to see your version, compare with the above, and reply back here.

I am unable to reproduce this problem on macOS High Sierra (10.13) installed on a USB flash drive. I tried both ImageJ 1.51r running Java 1.8.0_101 and a freshly downloaded copy of Fiji running Java 1.8.0_66.

1 Like

Hi Karsten_Ro,

Thanks a lot! According to your information, I added ij.jar to the Window sidebar and to a file area of Dock and started up ImageJ by clicking it. Now, I succeeded to launch it with the menu bar.

To cite a post by @jean-christophe.ame from the ImageJ mailing list:

Hi All,
just to inform the community that the menus of ImageJ1 and Fiji are back with the new final release 10.13.1 as well with the first beta 10.13.2.

Also Apple released a new version of Java6 compatible with High Sierra, search for Apple Java6 2017-001.

1 Like