Fiji in 32-bit Win7 does not start

Dear experts,
Hello!
I try to install Fiji in my 32-bit Win7 system, but it does not start, I mean that no window appears. I have upgraded my Java to Java 8, and edited my environment variables, but it did not work.
I have noticed that Dr. Bio7 said "You have to start FIJI with less Java memory on your 32-bit system (for instance with -Xmx512MB)."
Does this suggestion also fit my situation?
How do I start FIJI using less Java memory (ie. with -Xmx512MB)?
Could someone help me?
Thank you very much!

Could you please try to launch it in Debug mode? Just make a copy of the ImageJ-win32.exe called debug.exe and run that—it should pop up a console window which reports more details of the failure.

2 Likes


Dear Dr. Curtis Rueden,
Greetings,
I have uploaduped the debug console as a JPG image. In this image, the Chinese after ‘D:’ or ‘D:\’ means a installer folder. In addition, the RAM of my computer is 4.00GB (2.88 available). What is wrong with my program? Can you help me setup it smoothly?
Thank you very much!
Best regards,
Yang Ke

The key message here is:

Could not reserve enough space for 1253376KB object heap

This is a continual issue with 32-bit Windows systems: they have differing maximum amounts of memory they will let Java have. We already patched this problem once to reduce the maximum default size to 1224MB. But it seems that on your system, that is still not low enough.

See this freshly written troubleshooting section. And please let us know whether that works for you.

Dear Dr. Curtis Rueden,
I tried to fix the bug based on the troubleshooting section, but can not start it.
At first step, I downloaded the ImageJ.bat launcher, and saved it in my Fiji.app folder (I think it’s ImageJ folder which you indicated here), like figure 1.


Then I double clicked it, like figure 2.
At the third step, I still can’t start up FIJI (I think it’s ImageJ which you indicated here), so subseqently can’t run Edit :arrow_forward: Options :arrow_forward: Memory & Threads…, command.
Because of the above situation, the fourth step can not be executed.
Where am I wrong? Can you help me?
Thank you very much!
Best regards,
Yang Ke

Looks like that batch file is not good enough. I will test and update it now.

Dear Dr. Curtis Rueden,
If you develop a new batch file, please kindly tell me again.
Thank you for your reply and valuable help.
Best regards,
Yang Ke

I fixed a bug in the ImageJ.bat file. It is now working on my Windows 10 test system.

However, there is now another problem: when I run Edit :arrow_forward: Options :arrow_forward: Memory & Threads…, I see the error message “Could not write initial ImageJ.cfg!”

So I think we should abandon this batch file approach.

Instead, try the following:

  • Run Notepad

  • Paste in the following:

    .
    jre\bin\javaw.exe
    -Xmx512m -cp ij.jar ij.ImageJ
    
  • Save the file as ImageJ.cfg in your Fiji.app or ImageJ.app installation.

  • Try running ImageJ-win32.exe again.

You can replace the 512m with however many megabytes of memory you wish to give to ImageJ.

Very sorry this is all so complicated.

1 Like

Dear Dr. Curtis Rueden,
I have run Notepad++ and pasted the code like Figure1


Then I saved the file as ImageJ.cfg.cfg (I did not find a ‘cfg’ saving type, so I named the file as ‘ImageJ.cfg’ in ‘All types’ model) in my Fiji.app like Figure2
At last, I tried to run ImageJ-win32.exe, but it still couldn’t work.
Dear Dr. Curtis Rueden, I admire you for your expertise and dedication. I think you will find a good way to help me get over the bug.
Thank you very much!
Best regards,
Yang Ke

The file needs to be named ImageJ.cfg, not ImageJ.cfg.cfg. By default, Windows hides file extensions. :grimacing: :fire: You will need to show file extensions in order to name the file as required.

Dear Dr. Curtis Rueden,
I have run FIJI successfully under you guidance, like Figure 1.

Your code is very brilliant.
Very thanks for your expertise and time.
I wish you are all well and your work goes smoothly!
Best regards,
Yang Ke

1 Like