Fiji/ImageJ interface/menu is white text on white background

Hi
A basic Fiji/ImageJ question - when I start Fiji in linux I just get an empty window.
It turns out that it’s running but the menus are white text on a white background.
Kind of difficult to use!
Any ideas?

@arb

Unfortunately - I am not the person to help you in this. I don’t use linux - so cannot test it. But perhaps you can give us a bit more info… what version of ImageJ/Fiji/Java are you running? What is the configuration of your system?

Have you tried simply downloading/re-installing a newer version of Fiji to see if that does the trick?

I am using the latest version of Fiji and my system java -version reports openjdk 1.8.0_222-b10 although I note it ships with jdk1.8.0_172 anyway. Anything else I can try?

@arb Hi,
Were you able to solve this issue?
I am having the same problem with CentOS 7.

No, I’ve tried loads of workarounds but it still doesn’t work on Centos7.
And I’ve installed java-11 into the OS and tried that but it crashes.

I have identified a solution!

  1. use the full command not the ImageJ-linux64 wrapper
  2. remove the -Xincgc option
  3. use java-11 not java-8
  4. remove jars/FilamentDetector-1.0.0.jar

You must use ImageJ-linux64 --dry-run to get the full command.
Then remove the -Xincgc option
Then prefix the full path to your java-11 binary, eg.
/usr/lib/jvm/java-11-openjdk-11.0.3.7-1.el7.x86_64/bin/java -Dpython…blah blah net.imagej.Main

NOTE!
You must remove (or rename) jars/FilamentDetector-1.0.0.jar because that causes a crash.

NOTE!
You must use the full path to your java-11 installation, you cannot use --java-home
because the latter causes a crash where it tries to find libjvm.so in the wrong place.