Fiji fails to launch after update$ ./ImageJ-linux64
OpenJDK 64-Bit Server VM warning: ignoring option PermSize=128m; support was removed in 8.0
OpenJDK 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Error while executing the main() method of class 'net.imagej.Main':
java.lang.IllegalArgumentException: Invalid service: sc.fiji.filamentdetector.gui.GUIStatusService
        at org.scijava.service.ServiceHelper.createExactService(
        at org.scijava.service.ServiceHelper.loadService(
        at org.scijava.service.ServiceHelper.loadService(
        at org.scijava.service.ServiceHelper.loadServices(
        at org.scijava.Context.<init>(
        at org.scijava.Context.<init>(
        at org.scijava.Context.<init>(
        at org.scijava.Context.<init>(
        at net.imagej.ImageJ.<init>(
        at net.imagej.Main.main(
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        at net.imagej.launcher.ClassLauncher.launch(
        at net.imagej.launcher.ClassLauncher.main(
Caused by: java.lang.NullPointerException
        at java.util.ArrayList.addAll(
        at org.scijava.util.ClassUtils.getAnnotatedFields(
        at org.scijava.util.ClassUtils.getAnnotatedFields(
        at org.scijava.service.ServiceHelper.createServiceRecursively(
        at org.scijava.service.ServiceHelper.createExactService(
        ... 16 more

The workaround I just found to launch Fiji successfully:$ ./ImageJ-linux64 --ij1

Except, there is no Script Editor. So instead I read the error message, found that there is a faulty service “filamentdetector”, then search for a jar file in that had such a file:

$ cd
$ find -name "*jar" -exec grep -Hsli filamentdetector {} \;

… and found:


… which I disabled by renaming its extension:

$ mv FilamentDetector-1.0.0.jar FilamentDetector-1.0.0.jar-disabled

… and then launched Fiji successfully, the normal way, and with a Script Editor.


Of course that wasn’t going to be the end of it. Fiji was running inside a vncserver instance for remote desktop access. Upon launching the Script Editor, the window of the latter was larger than the screen, and that resulted in both Fiji crashing and the entire vncserver crashing. Now I’m stuck, because I can’t remember in which config file are the dimensions of the Script Editor saved.

So I took the nuclear option:

$ rm ~/.java/.userPrefs

… and restarted Fiji, and launched the Script Editor successfully.

@albertcardona I am having the same issue on Raspberry Pi. Your workaround can launch Fiji, but the content of menu bar are missing. I tried to click on any random menu and it seems functional. So, when you said that you can launch Fiji, do you see the content in the menu bar as normal?

Hi @ekawahyu,
When launched, the Fiji menu bar looks normal in my desktop.
There is a better workarond than using the param --ij1: rename the extension of the failing jar file under as shown above.
Hopefully soon a fixed jar file will be released via the “Help - Update Fiji”. Have you run it recently to check whether that’s the case already?

@albertcardona , I did rename the FileDetector-1.0.0.jar per your suggestion. The --ij1 does not seem to work on Raspberry Pi.

I am following the guide in here to get the latest Fiji (no JRE) installed and run on Raspberry Pi:

And then, I added your workaround (not the --ij1) on top of it. Still no luck with the menu bar. It is basically empty (but functional).

When I use the full version of RaspiOS, I can see the menu bar. But when I install raspberrypi-ui-mods on top of RaspiOS lite version, then Fiji has issue with missing menu bar (only on Fiji). I don’t bother to fix it and stick with the full desktop RaspiOS for now.