Fiji crash upon NanoJ start

Dear all,

I hope you had a good and healthy start in 2021. Getting back to the desk, I experienced problems when using any function of NanoJ plugins. I regular use the drift correction for my time lapse image sequences, although it wasn’t originally designed for this purpose it works better in my hand than for example TurboReg etc. However, when I’m starting up NanoJ Fiji will crash and close shortly after the status bar reports “Nanoj: loaded Open CL Interface…”

This happened to me already back in November after a Windows 10 update, but I could do a roll back and it worked again. As the last update was shortly before christmas, windows would not let me do that again.

Here is the header of the crash report:

# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x0000000054fcfb45, pid=592, tid=0x0000000000003858
#
# JRE version: Java(TM) SE Runtime Environment (8.0_172-b11) (build 1.8.0_172-b11)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.172-b11 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# V  [jvm.dll+0x13fb45]
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp

My System is nothing special, a 64-bit Windows Education Version run with a i5-6500 and a AMD R7 200.

What I tried so far:

  • Rolling back windows updates as far as I can
  • Updating, deinstallation and reinstallation of GPU Driver (Intel&AMD)
  • Using a fresh Fiji
  • Exchanging java in Fiji to some recent versions (Fiji won’t start up with Java>8)
  • Setting up a VM with a Pop-Os

The “Problematic Frame” points to a problem inside Java linked to OpenCl, however, I do not a have a clue what that could be. I would appreciate any help with this!