Failing to install deeplabcut on conda environment

Hello,
I have been attempting to install deeplabcut on my Windows 10 computer. I have run into a similar error as a post on April 11 (Error In pip install deeplabcut), but the error persists inside the dlc-windowsCPU environment. As a result, the module fails to install.

Does anybody know how to get around this problem?

can you confirm you are using the environment supplies here: www.deeplabcut.org, and NOT installing anything agan once activated? I.e. can you create this again and just try to import tensorflow?

Yes, I am in the conda environment dlc-windowsCPU when I have tried to install. What do you mean by create this again and just try to import tensorflow?

meaning, can you delete the environment (https://docs.conda.io/projects/conda/en/latest/user-guide/tasks/manage-environments.html#removing-an-environment), and re-created it (by downloading, and just running conda env create -f dlc-windowsGPU.yaml, but don’t add anything else to it. i.e. don’t run pip install, etc.

Hi there!

I am using conda 4.7.10 on Ubuntu 18.04.

Downloaded the yaml file for GPU: http://www.mousemotorlab.org/s/dlc-ubuntu-GPU.yaml

Besides β€˜base’ there are no other conda environments set up.

Then issued the command: conda env create -f dlc-ubuntu-GPU.yaml

Terminal output gives the following:

Collecting package metadata (repodata.json): done
Solving environment: failed

ResolvePackageNotFound: **
** - openblas==0.3.5=h9ac9557_1001

Did anyone else encounter this?

Edit: It does seem as if the blas package is broken based on info found here: https://anaconda.org/conda-forge/openblas/files?page=0
Edit2: Haven’t resolved this issue yet. Does anyone have a hint on how to proceed? Thx!

you can likely drop the openblas from the yaml file; the only real dependencies are
wxPython, deeplabcut, and tensorflow :slight_smile:

Progressed a bit futher, but now running into multiple package conflicts:

UnsatisfiableError: The following specifications were found to be incompatible with each other:
Package libgcc-ng conflicts for:
zlib==1.2.11=h7b6447c_3 -> libgcc-ng[version=’>=7.3.0’]
openssl==1.1.1c=h7b6447c_1 -> libgcc-ng[version=’>=7.3.0’]
libopenblas==0.3.6=h5a2b251_0 -> libgcc-ng[version=’>=7.3.0’]
readline==7.0=h7b6447c_5 -> libgcc-ng[version=’>=7.3.0’]
sqlite==3.28.0=h7b6447c_0 -> libgcc-ng[version=’>=7.3.0’]
xz==5.2.4=h14c3975_4 -> libgcc-ng[version=’>=7.2.0’]
ncurses==6.1=he6710b0_1 -> libgcc-ng[version=’>=7.3.0’]
c-ares==1.15.0=h14c3975_1001 -> libgcc-ng[version=’>=7.3.0’]
tk==8.6.8=hbc83047_0 -> libgcc-ng[version=’>=7.3.0’]
libprotobuf==3.8.0=h8b12597_0 -> libgcc-ng[version=’>=7.3.0’]
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> libgcc-ng[version=’>=5.4.0’]
python==3.6.8=h0371630_0 -> libgcc-ng[version=’>=7.3.0’]
libedit==3.1.20181209=hc058e9b_0 -> libgcc-ng[version=’>=7.3.0’]
libffi==3.2.1=hd88cf55_4 -> libgcc-ng[version=’>=7.2.0’]
numpy-base==1.14.6=py36h2f8d375_4 -> libgcc-ng[version=’>=7.3.0’]
hdf5==1.10.4=nompi_h3c11f04_1106 -> libgcc-ng[version=’>=7.3.0’]
Package protobuf conflicts for:
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> protobuf[version=’>=3.6.0’]
Package cudatoolkit conflicts for:
cupti==10.0.130=0 -> cudatoolkit=10.0
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> cudatoolkit[version=’>=10.0.130,<10.1.0a0’]
cudnn==7.6.0=cuda10.0_0 -> cudatoolkit[version=’>=10.0,<10.1’]
Package libstdcxx-ng conflicts for:
python==3.6.8=h0371630_0 -> libstdcxx-ng[version=’>=7.3.0’]
hdf5==1.10.4=nompi_h3c11f04_1106 -> libstdcxx-ng[version=’>=7.3.0’]
ncurses==6.1=he6710b0_1 -> libstdcxx-ng[version=’>=7.3.0’]
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> libstdcxx-ng[version=’>=5.4.0’]
libprotobuf==3.8.0=h8b12597_0 -> libstdcxx-ng[version=’>=7.3.0’]
libffi==3.2.1=hd88cf55_4 -> libstdcxx-ng[version=’>=7.2.0’]
Package zlib conflicts for:
tk==8.6.8=hbc83047_0 -> zlib[version=’>=1.2.11,<1.3.0a0’]
python==3.6.8=h0371630_0 -> zlib[version=’>=1.2.11,<1.3.0a0’]
libprotobuf==3.8.0=h8b12597_0 -> zlib[version=’>=1.2.11,<1.3.0a0’]
hdf5==1.10.4=nompi_h3c11f04_1106 -> zlib[version=’>=1.2.11,<1.3.0a0’]
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> zlib[version=’>=1.2.11,<1.3.0a0’]
Package absl-py conflicts for:
tensorflow-estimator==1.13.0=py_0 -> absl-py[version=’>=0.1.6’]
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> absl-py[version=’>=0.1.6’]
Package python conflicts for:
pip==19.1.1=py36_0 -> python[version=’>=3.6,<3.7.0a0’]
mock==3.0.5=py36_0 -> python[version=’>=3.6,<3.7.0a0’]
werkzeug==0.15.4=py_0 -> python
setuptools==41.0.1=py36_0 -> python[version=’>=3.6,<3.7.0a0’]
tensorflow-estimator==1.13.0=py_0 -> python
gast==0.2.2=py_0 -> python
tensorflow==1.13.1=gpu_py36h3991807_0 -> python=3.6
certifi==2019.3.9=py36_0 -> python[version=’>=3.6,<3.7.0a0’]
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> python[version=’>=3.6,<3.7.0a0’]
numpy-base==1.14.6=py36h2f8d375_4 -> python[version=’>=3.6,<3.7.0a0’]
Package certifi conflicts for:
setuptools==41.0.1=py36_0 -> certifi[version=’>=2016.09’]
Package numpy conflicts for:
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> numpy[version=’>=1.13.3,<2.0a0’]
tensorflow-estimator==1.13.0=py_0 -> numpy[version=’>=1.13.3’]
numpy-base==1.14.6=py36h2f8d375_4 -> numpy==1.14.6=py36hec00662_4
Package astor conflicts for:
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> astor[version=’>=0.6.0’]
Package liblapacke conflicts for:
libblas==3.8.0=7_openblas -> liblapacke==3.8.0=7_openblas
libcblas==3.8.0=7_openblas -> liblapacke==3.8.0=7_openblas
liblapack==3.8.0=7_openblas -> liblapacke==3.8.0=7_openblas
Package cudnn conflicts for:
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> cudnn[version=’>=7.3.1,<8.0a0’]
Package _libgcc_mutex conflicts for:
libgcc-ng==9.1.0=hdf63c60_0 -> _libgcc_mutex=[build=main]
Package openblas conflicts for:
blas==1.0=openblas -> openblas
libblas==3.8.0=7_openblas -> openblas=0.3.5
Package mock conflicts for:
tensorflow-estimator==1.13.0=py_0 -> mock[version=’>=2.0.0’]
Package keras-preprocessing conflicts for:
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> keras-preprocessing[version=’>=1.0.3’]
Package readline conflicts for:
python==3.6.8=h0371630_0 -> readline[version=’>=7.0,<8.0a0’]
Package liblapack conflicts for:
libblas==3.8.0=7_openblas -> liblapack==3.8.0=7_openblas
libcblas==3.8.0=7_openblas -> liblapack==3.8.0=7_openblas
Package libcblas conflicts for:
liblapack==3.8.0=7_openblas -> libcblas==3.8.0=7_openblas
libblas==3.8.0=7_openblas -> libcblas==3.8.0=7_openblas
Package libgfortran-ng conflicts for:
hdf5==1.10.4=nompi_h3c11f04_1106 -> libgfortran-ng[version=’>=7,<8.0a0’]
numpy-base==1.14.6=py36h2f8d375_4 -> libgfortran-ng[version=’>=7,<8.0a0’]
libopenblas==0.3.6=h5a2b251_0 -> libgfortran-ng[version=’>=7,<8.0a0’]
Package tk conflicts for:
python==3.6.8=h0371630_0 -> tk[version=’>=8.6.8,<8.7.0a0’]
Package cupti conflicts for:
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> cupti
Package libblas conflicts for:
liblapack==3.8.0=7_openblas -> libblas==3.8.0=7_openblas
libcblas==3.8.0=7_openblas -> libblas==3.8.0=7_openblas
Package libedit conflicts for:
sqlite==3.28.0=h7b6447c_0 -> libedit[version=’>=3.1.20181209,<3.2.0a0’]
Package libopenblas conflicts for:
numpy-base==1.14.6=py36h2f8d375_4 -> libopenblas[version=’>=0.3.3,<1.0a0’]
Package openssl conflicts for:
python==3.6.8=h0371630_0 -> openssl[version=’>=1.1.1a,<1.1.2a’]
Package blas conflicts for:
numpy-base==1.14.6=py36h2f8d375_4 -> blas=[build=openblas]
libblas==3.8.0=7_openblas -> blas=[build=openblas]
liblapack==3.8.0=7_openblas -> blas=[build=openblas]
libcblas==3.8.0=7_openblas -> blas=[build=openblas]
Package pip conflicts for:
python==3.6.8=h0371630_0 -> pip
Package gast conflicts for:
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> gast[version=’>=0.2.0’]
Package _tflow_select conflicts for:
tensorflow==1.13.1=gpu_py36h3991807_0 -> _tflow_select==2.1.0=gpu
Package termcolor conflicts for:
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> termcolor[version=’>=1.1.0’]
Package wheel conflicts for:
pip==19.1.1=py36_0 -> wheel
Package keras-applications conflicts for:
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> keras-applications[version=’>=1.0.5’]
Package setuptools conflicts for:
pip==19.1.1=py36_0 -> setuptools
Package xz conflicts for:
python==3.6.8=h0371630_0 -> xz[version=’>=5.2.4,<6.0a0’]
Package sqlite conflicts for:
python==3.6.8=h0371630_0 -> sqlite[version=’>=3.26.0,<4.0a0’]
Package six conflicts for:
tensorflow-estimator==1.13.0=py_0 -> six[version=’>=1.10.0’]
mock==3.0.5=py36_0 -> six
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> six[version=’>=1.10.0’]
Package grpcio conflicts for:
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> grpcio[version=’>=1.8.6’]
Package tensorflow-estimator conflicts for:
tensorflow-base==1.13.1=gpu_py36h8d69cac_0 -> tensorflow-estimator[version=’>=1.13.0,<1.14.0a0’]
Package tensorflow-base conflicts for:
tensorflow==1.13.1=gpu_py36h3991807_0 -> tensorflow-base==1.13.1=gpu_py36h8d69cac_0
Package libffi conflicts for:
python==3.6.8=h0371630_0 -> libffi[version=’>=3.2.1,<4.0a0’]
Package ca-certificates conflicts for:
openssl==1.1.1c=h7b6447c_1 -> ca-certificates
Package ncurses conflicts for:
libedit==3.1.20181209=hc058e9b_0 -> ncurses[version=’>=6.1,<7.0a0’]
python==3.6.8=h0371630_0 -> ncurses[version=’>=6.1,<7.0a0’]
readline==7.0=h7b6447c_5 -> ncurses[version=’>=6.1,<7.0a0’]
Package tensorboard conflicts for:
tensorflow==1.13.1=gpu_py36h3991807_0 -> tensorboard[version=’>=1.13.0,<1.14.0’]Preformatted text

seems quite strange to me. I am mostly running conda on 16.04, and at this point my servers run 18.04 but use Docker (which you might want to consider, it’s amazing :slight_smile: )

Otherwise, you can also just try to make a fresh env yourself; ubuntu is much better for this. i.e.

conda create -n DLC2 python=3.6
then:
source activate DLC2
then run:
pip install deeplabcut
wxPython for 18.04:

either: pip install wxpython==4.0.3 or:
pip install https://extras.wxpython.org/wxPython4/extras/linux/gtk3/ubuntu-18.04/wxPython-4.0.3-cp36-cp36m-linux_x86_64.whl
TF:
pip install tensorflow-gpu==1.14

that should be it.

Great. Thanks so much for the guidance.

no problem! thanks for using DLC :slight_smile:

1 Like