Failed upload to http://sites.imagej.net/

Hello,
sorry for being hopeless but I tried to upload what I consider to be a useful plugin to sites.imagej.net/ today under the page /ResultsToExcel and I think I have done something wrong. Firstly, there are multiple entries for each .jar file. Secondly, when I try to call the plugin from a virgin Fiji build (fresh download from http://fiji.sc/Download) using the update site:
http://sites.imagej.net/ResultsToExcel
then only the dependency libraries are installed to ImageJ/Fiji, and the plugin is not available for download.

Also, when I created a wiki page, I first named it “Read_and_Write_Excel”. This successfully created an account on http://imagej.net/ but failed to create a simultaneous http://sites.imagej.net update page of the same name. I’m guessing this was because of the underscores as there is now another update page http://sites.imagej.net/Read which I cannot upload to with my password.

Sorry for the fuss,
Anthony

@antinos You might have hit a bug here. Looking into the db.xml.gz on your update site, I see:

<plugin filename="plugins/Read_and_Write_Excel-1.0.0.jar">
        <platform>Created in Eclipse IDE Mars.1 release (4.5.1)</platform>
        <platform>using the java jdk1.6.0_45 for ImageJ compatibility.</platform>
        <category>Input/Output.
Export data to file. Batch tested.</category>
        <version checksum="61e9f509a2282fb3ae1fad55523d40b5a4d6444d" timestamp="20151119194050" filesize="15842806">
            <description> [... (omitted for clarity) ...] </description>
            <dependency filename="jars/xmlbeans.jar" timestamp="20151119171906"/>
            <dependency filename="jars/poi-ooxml.jar" timestamp="20151119171906"/>
            <dependency filename="jars/poi-ooxml-schemas.jar" timestamp="20151119173250"/>
            <dependency filename="jars/poi.jar" timestamp="20151119173250"/>
            <dependency filename="jars/ij.jar" timestamp="20151116123442"/>
            <author>Anthony Sinadinos</author>
        </version>
</plugin>

What confuses me are the two <platform> tags in the beginning. What were the steps you took to upload the files? Did you enter the platform specifiers manually during upload? Can you try what happens if you delete the platform entry?

This seems to be a bug as well.

1 Like

Okay, just deleted the platform entry and the fresh Fiji download has the plugin. Thanks for your help.
I modified the platform field in the ImageJ updater advanced ‘Details’ window to something I thought was appropriate:
"Created in Eclipse IDE Mars.1 release (4.5.1), using the java jdk1.6.0-45 for ImageJ compatibility."
but I didn’t really know what needed to go there. It looks like the updater might have broken the entry at the comma.

Regards,
Anthony

@antinos Glad that it worked for you!

According to the updater source code, the platform should be empty or one of linux32, linux64, macosx, tiger, win32, win64, so that the updater offers those files only for the platforms specified (which is useful in the case of native libraries). The updater could be improved to prevent invalid input like yours instead of simply ignoring it. Please feel free to open an issue at https://github.com/imagej/imagej-updater/issues

If you develop your plugin with Maven, e.g. by starting from the minimal plugin template, the updater should automatically fill in the file information from the info in the pom.xml, so you don’t need to add it manually.

1 Like

Thanks for all the advice,
I’ve uploaded another version with the win64 tag as the saving to desktop portion of the plugin may not work outside windows. Just another question, and sorry again for being naïve, when I upload to mysite from the updater do I need to modify the file name or request files take-downs or can I rely on the fact that the most recent upload be the one that is accessed by others? I can see on http://sites.imagej.net/ResultsToExcel that multiple versions of files exist at present.

As you may have worked out, I didn’t construct my plugin using the minimal imageJ template or Maven hierarchies. I also haven’t uploaded source to GitHub yet either, so I haven’t exactly adopted best-practice principals. I’ll try to rectify these mistakes soon.

If you think it is worth it, I can open an issue on GitHub. However, I doubt my errors would be repeated by too many other people.

Best regards.

The reason multiple versions exist on the remote server is because all previous versions are saved forever, version control style. This is normal and expected.

To see what is currently being served on your update site, change the “View” filter of the updater’s advanced mode to “Files of the ‘ResultsToExcel’ update site”.

If you want to stop a file from being served, you can mark it obsolete.

1 Like

I began to think as much, but thank-you for the confirmation. Since posting the question, I have also realised that this information is available on the ‘update site FAQ’, so sorry for asking somebody to repeat it.

on a side note, the most recent version of the plugin .jar now also contains the .java file, in case it interests you to incorporate the used method in other Imagej/Fiji tools.

Regards

2 Likes