Failed to load tiff with openslide in Windows

It can be read in Linux. I tried to reinstall openslide several times but I still get the same problem.

I’m not sure if you just need to escape the \ characters or use a raw string, e.g. use ‘“D:\\testdata\\1.tiff”’ or see this stackoverflow answer:

Otherwise, please provide more info about the tiff. I notice the post is tagged qupath and bio-formats, but neither seems relevant unless they were used to write the image in the first place.

I was trying to open a mrxs on windows using QuPath. It could only load the smallest level. But I can zoom it with QuPath on Linux. My openslide on Linux works fine with tiff and mrxs, too. But it showed the bug on windows. I found it really wired.

This sounds like a different problem from opening the tiff using Python in a Jupyter notebook.

To help understand why the image doesn’t open for you on Windows, I would need a lot more information about specifically what exactly you have tried to do (e.g. version of QuPath, any special steps involved, any specific error messages you see – including under View → Show log).

1 Like

Thank you. Sorry for the late reply. I am using Qupath 0.2.3 . I load my mrxs into Qupath,
image
QuPath can read tiff properly on Windows but not the mrxs. It seems that both both Qupath and openslide showed the same error. I am wondering if there is something wrong with my openslide or I did not install it properly.

INFO: Initializing type adapters
INFO: Bio-Formats version 6.5.1
INFO: Loaded extension Bio-Formats options (Bio-Formats 6.5.1) (19 ms)
INFO: Loaded extension Experimental extension (1 ms)
INFO: Loaded extension ImageJ extension (48 ms)
INFO: Loaded extension JPen extension (16 ms)
INFO: Loaded extension Processing extension (28 ms)
INFO: Loaded extension Rich script editor extension (295 ms)
INFO: Loaded extension SVG export extension (1 ms)
INFO: OpenSlide version 3.4.1
INFO: Starting QuPath with parameters:
INFO: Performing update check…
INFO: Current version 0.2.3, latest stable release 0.2.3 - nothing to update
WARN: Temp memoization directory created at C:\Users\mingh\AppData\Local\Temp\qupath-memo-9398674494887429007
WARN: If you want to avoid this warning, either disable Bio-Formats memoization in the preferences or specify a directory to use
WARN: Unable to open file:/D:/GMH/正式实验芯片-2.mrxs with OpenSlide: Couldn’t open D:\GMH\正式实验芯片-2\Slidedat.ini: No such file or directory
WARN: Unable to open UriImageSupport (class qupath.lib.images.servers.openslide.OpenslideServerBuilder) support=2.5, builders=1
INFO: Image data set to ImageData: Not set, 正式实验芯片-2.mrxs

The problem is likely to be the filename. See this OpenSlide bug report:

1 Like