Failed to launch JVM when open tiff file

I have met a question. Our team are developing a deep learning tool with Motic scanner. We have to transfer ‘mds’ format to ‘tif’, then annotate carcinoma region with qupath.And there are some tif files failed open with qupath and notioned “Failed to launch JVM” or “java have no space”, we check these images with ASAP and PMA.start and they are openable.

I believe it’s too big for qupath to open it ,butI cann’t increase my allocate memory as below.qupath-setup

I think this will be the first time I’ve linked to a twitter post as an answer, but have you tried:

@yasohasakii I’d need to know more about what exactly you’re doing, including

  • what version of QuPath are you using?
  • how are you opening the image?
  • what precisely is the error message? (ideally the full stack trace if you can find it in the log)

‘Failed to launch JVM’ suggests that QuPath couldn’t be started at all, which leads me to think that you are doing this from the command line. But I would need to know exactly the steps to help further.

1 Like

Changed cfg file but failed again.
I’m using QuPath-0.2.0-m5, and if it’s convenient for you to offer a email address, I’d like to send you the raw tif image I failed to open.
I found these in system info

Version: 0.2.0-m5
Build time: 2019-11-01, 22:38
Latest commit tag: ‘1a263ca9’
Java version: 11.0.4
Java vendor: AdoptOpenJDK - https://adoptopenjdk.net/
Java home: D:\Programes\qupath\runtime
Operating system: Windows 10 - 10.0
Architecture: amd64
Number of available processors: 4
Memory already used by JVM: 36 MB
Total memory available to JVM: 128 MB
Max memory JVM may try to use: 14336 MB

But I cann’t find proper log file in my install directory.

You can force QuPath to use OpenSlide to open the image using the method described at https://github.com/qupath/qupath/issues/382

This works for me, but it remains very slow. The reason for that is that the image is very large but only has two pyramid levels (full-resolution and downsampled by a factor of 4). You may be able to speed this up by creating a tiff with more pyramidal levels (e.g. using VIPS).

(Bio-Formats seems to be treating the image as having a single resolution, which is what causes the memory error.)

2 Likes

actually I can change the downsample factor but I don’t know which number the factor can speed it up.

Ideally you would have multiple downsample factors (e.g. 1, 4, 16…). The lowest resolution image should perhaps be 1000-5000 pixels in width and height.

Ok ,I’d try a few moment later,thanks a lot.

Hi Pete. How can I open the annotation file .qpdata if I changed source TIF file path? Like I copied them it into another folder, it shows “JVM Failed” again, thanks.

@petebankhead I found when I open .qpdata with Notepad++ instead of QuPath, I could see file path has been writen in .qpdata file like below, I tried to change that with the TIF file path right now and open with QuPath, but failed again. So it cann’t solve my problem.

When you say ‘JVM Failed’ does that mean you are trying to open the file by double-clicking on it?

In v0.1.2 you should try opening the .qpdata file by dragging it onto QuPath while it is running, and then you should have the opportunity to change the path.

However, it is strongly recommended to use a Project rather than separate .qpdata files - especially with new milestone versions. You can edit the project file in a text editor (not the .qpdata file), but in recent milestones you shouldn’t have to because I’ve made changes to address precisely this issue: https://petebankhead.github.io/qupath/2019/08/20/fourth-milestone.html#repair-projects-by-finding-missingmoved-images

So if I had not create Project then I couldn’t change URIs, I tried drag qpdata to QuPath and still failed.
qupath-problem2

You could create a project with the same images, locate the .qpdata file for the image (right-click on the entry under the ‘Project’ tab in QuPath and choose Open directory… → Project entry…) and replace it with yours.

1 Like

Hi Pete!I tried this way in my laptop and it worked, but not successed in my colleague’s PC, her QuPath showed as below, that’s why.
捕获

forgot to mention that her QuPath version is 0.2.0-m5, and mine is 0.2.0-m8. Is high version imcompate lowers?

Yes, that will be the reason - GeometryStats wasn’t present (or at least wasn’t serializable) in the earlier version.

OK, I’d tell her to updata QuPath to m8 version, thx.