ExportToSpreadsheet Image|ModuleError_21Track Objects is not one of the choices

Hello,

this is a new one for me and I am scratching my head!
First the basic info:

The pipeline used to run just fine and I have managed to run all the steps until Export to Spreadsheet whigh gives this weird error.
I have also tried re-creating the pipeline and get the same error.
In addition I have the following warnings in the terminal

cellprofiler\modules\saveimages.py:751: UserWarning: E:\_OUTPUT\_RUNS\RUN_Endo\CP_Output\Untreated_20180427_Pos01_cl16_NucleiLabel\Untreated_20180427_Pos01_cl16_Nuclei-label-0.tiff is a low contrast image
cellprofiler\modules\relateobjects.py:617: FutureWarning: Using a non-tuple sequence for multidimensional indexing is deprecated; use `arr[tuple(seq)]` instead of `arr[seq]`. In the future this will be interpreted as an array index, `arr[np.array(seq)]`, which will result either in an error or a different result.
cellprofiler\modules\saveimages.py:751: UserWarning: E:\_OUTPUT\_RUNS\RUN_Endo\CP_Output\Untreated_20180427_Pos01_cl16\Untreated_20180427_Pos01_cl16_NucleiClassesTelo\Untreated_20180427_Pos01_cl16_classtelo_0.png is a low contrast image

I am at a loss as it worked and I just added an additional Filter (by areashape) but I still have objects so it is not an issue of having nothing to track (plus in test mode all modules until export run fine).
Any idea?

image
I get this when I try to recreate the pipeline from a functioning one…

but when I re-import a new ExportToSpreadsheet module with exactly the same settings… works!

So this is because you are only exporting certain results in ExportToSpreadsheet, so it had to make a list of explicit measurements you wanted out, and you’ve now changed the module numbering scheme by inserting new modules, so TrackObjects is now no longer module 21 but say, number 22. ExportToSpreadsheet is now letting you know that your explicit listing is now incorrect.

To fix, just go into your list of measurements you are exporting in ExportToSpreadsheet (the “press here to select measurements” button), un-select and re-select any category that’s giving an error (should only be things in the image category, and even there only certain things like module error and execution times), and the error should resolve.

mind blown!

If I just selected the measurements in the Image category (and experiment etcc), the error sign remained. but it worked but only after I had rerun also the first 4 modules (and went into test mode). so a bit of a lag but still OK.

Side-note: is it possible to addd numbers next to the modules (as in the export measurements view) that’d be nice add-on especially when modifying pipelines from existing ones.

thanks again!
Cheers

Debbi