Export to Spreadsheet Error Does Not Refresh Error Status

CP development staff: After using CP and becoming a bit more familiar with the interface I have been noticing the “Export to Spreadsheet” function is either slow to refresh, or does not refresh when corrections are made to the data export. For example, if I were to add a measurement and then change the name of that measurement, an error would appear on the “Export to Spreadsheet” process in the pipeline. If I were then to go back and correct the error by changing the entry in the “Export to Spreadsheet” dialog window, the error does not go away. I believe that sometimes this may also create a false error when trying to analyze images, but processing will succeed if user selects the button in the error dialog. I have found that if I (1) save the project, (2) shut down CP, (3) reopen CP, and (4) reopen the saved project, the error goes away and CP runs without any problem. Best, PjB

Thanks for this. I just tried changing an on object name (“Cells” -> “CellsX”) and as expected, ExportToSpreadsheet warns me that there is no longer “Cells” object (assuming I had chosen to only export certain objects). However when I change the object name from Cells to CellsX in ExportToSpreadsheet, it does take a number of seconds, but the pipeline does eventually validate and the red exclamation point and red warning text within the module do go away. Is it possible you had a long pipeline (which takes longer to validate all the settings) and didn’t wait long enough to see it validate?

Also note that there are some settings (in some measurement modules I think?) that you need to actively click on, even if they look to be set properly. This bug has been fixed recently, but is not in the current release, so after you change your measurement name, you might need to check all your red warning signs and actively re-click any of those settings.

Does that help?
David

Hi David, Thanks for the feedback, but this does not seem to work for me. I have seen this on both Win7 and Win8.1. I have also noted that if I persist and move into test mode to validate pipeline and then exit after sometime, the error call similar to what you describe does disappear, but the exclamation point persists for an indefinite period and says that the “export to spreadsheet” function will not work in test mode despite having exited test mode for a period of time. Interestingly, this does not go away until I save my project, restart CP and then reload project. My pipelines are not extravagant. Current pipeline is about 7 items deep (couple illumination corrections and identify primary objects, then measurements prior to export. I might add that the PC’s are quite fast and this occurs even when I have a couple of images loaded in the project. I also had trouble loading images in CP when the interface was trapped in this “error” state. The only way I could load images was individually by browsing for images after selecting “load images” after right click. Very strange. Any help is appreciated.

Would you mind posting your pipeline and a couple images? And also please tell us exactly what you are changing to reproduce this behavior.
Do you see a red triangle, or a yellow triangle warning?

Thanks,
David

Thanks David. I posted a zip file with pipeline, images, and a PDF with screenshots of what I am doing and seeing in the CP. In brief, I do the following:

Process to create “Export to Spreadsheet” failure to refresh state:

  1. change primary object names Nuclei to NucleiD and Puncta to PunctaR (or reverse process)
  2. update subsequent pipes to reflect changes to object names in “Measure Image Area Occupied”.
  3. reselect the appropriate measures for output in “export to spreadsheet” tool.
  4. the error lingers on the export to spreadsheet indefinitely.

As I stated previously this seems to happen on both Win7 and 8.1. In addition, the consequences seem more severe on Win7, but I will confirm in the following days whether or not drag and drop images is bound to the behavior of “Export to Spreadsheet” state refresh. UPDATE: I have confirmed that these behaviors are not related and is only coincidental on Win7 which means that I am having drag and drop image file problems in Win7, but I will post this under CP Help.

UPDATE1: We see the same error refresh problem with “Export to Spreadsheet” on MAC OS.

Thanks Again for your help, Paul
CP_Exp2Sprdsht.zip (3.83 MB)