Export problem with cytomap

Hello ,
I have a problem when I want to export my data under Cytomap. It does not work … I can select the folder and follow the procedure described here ([There and back again, QuPath<==>CytoMAP cluster analysis - #4 by Mike_Nelson]). Nothing is loading and I don’t understand why … :thinking:

Thanks for your help

:innocent: Sorry for my English, I’m Frenchy :sweat_smile:

Hi!

Could you clarify which step or steps are not working? I do not think I understand the question. It would also help to understand what types of data you are trying to work with, and what the CSV file looks like (a screenshot would help).

Are you unable to load any data into CytoMAP? Can you create a basic CSV file with only a few lines and see if that works? Which version of CytoMAP are you using?

Cheers,
Mike

Hi :slight_smile:
So, I manage to import my data from qupath to Cytolab.

I make my gates etc…

And, when I want to export my data (to import them then into qupath), nothing happens … No file is created in the selected folder. And I have a windows bug sound :frowning:


I am not 100% sure, but are you sure you have selected a folder? In the image, it looks like it might be looking for the folder “IHC” inside of the IHC folder.

But there is no IHC folder there, just KI67 and Nouveau dossier folders.

Might it be looking for a folder that does not exist?

I tried to create a new folder, and still the same

Hmm, I do not think that is something I have encountered. Could you try the export on a different computer?

Oki, I will try today at work :slight_smile: I will tell you :crossed_fingers:t2: :crossed_fingers:t2:

Hi :slight_smile:

I tried on another computer, it works :smiley: :smiley:

Now I have another problem .(I know…).
I cannot import into qupath …

1 Like

Back to the first point, it might be that you would need to run CytoMAP “As administrator” or save to a different file location, some file systems protect certain areas from non-admin programs writing new files to them (security issues).

As for the new issue, it looks like the CSV file is not matching up to any of the cells. I assume the cells exist in the file you are importing to? You won’t be able to import into a blank QuPath image - all you are doing is editing the Measurement list of the cell objects that already exist.

Hi :slight_smile:

sorry for my late response, family weekend :slight_smile:

I found the solution :slight_smile:
problem 1: I reinstall my computer :wink:

problem 2: I am working from an image scan in .ndpi (hamamatsu scanner), and the import was not working. So I made an annotation of my interest zone, then I exported this annotation to have a TIFF image.

I opened cytomap, etc. and import the data into quPATH and it works :slight_smile:

thank you very much for your help :grinning: :grinning: :grinning:

1 Like

There have been some other mentioned of NDPI files that have not worked well with QuPath, depending on the system and how recent the scanner is. Sometimes the NDPI file works when you force “Bioformats” as the import server.

If you could provide more details about any error message, a sample file (on google drive or similar), or check whether the NDPI file fails on both Openslide and Bioformats, that may help @petebankhead in the future. Also, the operating system you are running QuPath on may be a factor as well.

in fact my ndpi file works perfectly under qupath, I can make my annotations etc. I can export the measurements to open them in cytomap (all the beginning of my post), but when I want to re-import from cytomap to qupath it does not work (error message with X and Y coordinates not found).

And by doing the exact same procedure with a tiff extracted from this scan, it works.

1 Like

Interesting, I know Openslide had some issues with the coordinate system which may impact the XY coordinates. Could you try creating a new project, opening the NDPI file with BioFormats, and testing a small area to see if the import works?

It works :slight_smile:

when we open the NDPI file with BioFormats, I can import my data from cytomap :slight_smile:

Thank you so much :slight_smile:

1 Like